I am new to Linux and have tried to set up a dual-boot with Windows Vista and Ubuntu Linux using a disk partition. I have successfully partioned the disk with Windows on one partition and Linux on the other using the automatic partition function during the Linux installation. My problem is that I cannot boot from the Windows partition and I don't know enough to fix it. Please help.

More information please. When you start up your computer, is an option to boot Windows listed anywhere in GRUB (the bootloader)? What is the output on the screen?

No, the option to boot Windows is not listed when GRUB comes up. When I boot up it gives me the option to load Ubuntu normally, in recovery mode, or run a memory test if I hit ESC.

If it helps, Windows was loaded on the computer to begin with and the Linux installation came after. During the Linux installation I used the automatic partitioner and partitioned the hard drive into 2 even halves. I only know that Windows is on the other half because I used Disks Manager and I was able to see that all the Windows files are on one of the partitions.

First of all, kick GRUB into command line mode by hitting 'c'. Then, see if entering the following lines do anything:
(I'm assuming that your Windows partition is the first one on the drive. If it's the second, replace the 0 after the first comma with a 1.)

rootnoverify(hd0,0)
makeactive
chainloader +1

Let us know if it works. If it does, I can show you how to edit your configuration file to add a Windows option.

I've been having the same trouble as tringler, and have been following the advice. Unfortunately, I have still been unable to boot into vista. It had been mentioned how to edit conf file to add a windows option. could you explain that please?

For a menu option to be any good, the commands it runs have to work. A Windows option in the Grub menu would use something similar to the commands listed above, so you should verify that the commands I posted work for you. What happens when you enter those into the Grub command line? Post any error messages you get.

I tried the 3 commands:
rootnoverify (hd0,0)
makeactive
chainloader +1
and go no error messages. Unfortunately, I'm one of those who installed Ubuntu onto a PC where Windows was installed onto a recovery partition :(
After the Ubuntu install, I installed Windows XP again, using the recovery CDs provided with the PC, but of course Ubuntu's grub config file didn't know that :)
Can anyone help me here?

So what you're saying is that Ubuntu is still there, but the GRUB menu no longer shows up when your computer boots?

So what you're saying is that Ubuntu is still there, but the GRUB menu no longer shows up when your computer boots?

Not exactly. What happened is that I damaged the partition table when rebuilding the PC OSes. I then ran Ubuntu setup to fix the partition table, creating a boot partition plus 1 other for Windows XP, and the remaining partitions for Ubuntu. I then restored XP using my recovery CDs. As the restore followed the Ubuntu installation, there were no entries in the grub menu.lst file for XP. After my last posting, I then reinstalled Ubuntu, and found that the following entries were automatically added to menu.lst :

<begin text quote>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
title Other operating systems:
root

# This entry automatically added by the Debian installer for a non-Linus OS
# on /dev/sda1
title Microsoft Windows XP Professional
root (hd0,0)
savedefault
makeactive
chainloader +1
<end text quote>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

After this, both Ubuntu and XP worked fine. I had also prior to the 2nd Ubuntu installation found that the rootnoverify, makeactive and chainloader commands, followed by the boot command, could be used to boot XP manually. I was *about* to insert that into the menu.lst file to fix the problem permanently, but while XP was booted up, I thought I'd use Norton Partition Magic to format the 2nd Windows partition. What a stupid idea that was! After that, grub exited with (I think) error 17 on bootup. This is why I installed Ubuntu for the 2nd time. Oh well, live and learn :)

So it's all good now, and I learned a bit about grub and dual-boot in the process. Thanks for the feedback, btw.