0

Hi,
I have installed SUSE10.0 over VMware Workstation 6.1. I was stupid enough to allocate only 8GB of space where I installed everything within that space(webmin...Apache2...etc.) and very little space remains back. Now after all when I tried to Install VMware tools it is throwing an error while trying to create the directory in /usr/bin for the binary files for VMware

There is insufficient disk space /usr/bin. Please make atleast an addtional 488k available or choose another directory

I did say that disk space is low but it is never that low that even 488k is not available. No matter whatever I try...(I have even deleted some 52MB file manually->a BeOS image file) and still not been able to install this. Whichever directory I try the same error gets repeated there too.

What do you think could be the prob? PLease help past two months I could not rectify this. And unfortunately (or I'm real dumb) I did not create any snapshot.

Please help me with this weird problem

3
Contributors
6
Replies
7
Views
10 Years
Discussion Span
Last Post by shouvik.d
0

Maybe that folder is on some other partition? fdisk -l

If it really is out of space, I'd try adding another drive and mounting that folder to it.

fdisk ... (fdisk /dev/hdb)
tar up /usr/bin ... (tar --create --verbose --gzip --file ub.tgz /usr/bin/*. )
create fs ... (mkfs -t ext3 /dev/hdb1)
mount usrbin ... (mount -t ext3 /dev/hdb1 /usr/bin)
extract ... (tar --extract --verbose --gunzip --preserve-permissions --file ub.tgz)

0

>Maybe that folder is on some other partition? fdisk -l
That may not necessarily provide enough information. The real info is when you run the mount command:

mount

It'll list all the filesystems mounted, and if /usr or /usr/bin is listed there, you've got it on a separate partition.

>mount usrbin ... (mount -t ext3 /dev/hdb1 /usr/bin)
What about the /etc/fstab file? :icon_wink: It sure isn't going to be very nice if you have to manually mount the filesystem each time you boot the system.

0

By the way - Depending on what you need it for, you might check VMWare's site to see if there's a SUSE based virtual appliance for it

Actually VMware doesn't have SUSE compatible drivers. So while installing it does a make by itself by using SUSE libraries and then only install. As a matter of fact I had once successfully installed VMware Tools in it and all features like time syncronization, resize, mouse capture etc. were working fine but then due to NIC issues I had to unistall it. Next time onwards I'm facing this error. There are no previous instances of the installation but then this error keeps coming. I m sure I'm having more than 107MB of space. Also since this is a virtual drive I am not able to expand it.

Hope you get the actuall scenario by now

0

Can I add any Virtual Hard Disks to already existing vmdk files. If so then part of my problem gets solved.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.