0

Hello, I was just hoping for a bit of help or for someone to point me in the right direction. Okay, so this past August, I found a really old windows 98 machine (433mhz processor and 96mb of ram). I decided to put slackware on it, and mess around with it a bit.

So, I now have a ssh and irc server running from it (schulte.homelinux.com), but now I am trying to configure apache to work properly. I have installed apache successfully, but for some reason I cannot access the apache server. I have port forwarding enabled for the router on port 80... but try it yourself: schulte.homelinux.com just loads forever and gives me a timeout error. :(

Basically, I am trying to set up a forum-based website on schulte.homelinux.com (I got the domain from dynDNS).. so yeah, any help would be swell.

4
Contributors
21
Replies
22
Views
10 Years
Discussion Span
Last Post by josh2
0

Um, I'm not sure.. the server is set up at my house, and I'm at college now. I access it via the ssh server.

0

Starting Nmap 4.20 ( http://insecure.org ) at 2007-11-01 10:57 CDT
Interesting ports on server.schulte (127.0.0.1):
Not shown: 1690 closed ports
PORT STATE SERVICE
22/tcp open ssh
37/tcp open time
53/tcp open domain
113/tcp open auth
139/tcp open netbios-ssn
445/tcp open microsoft-ds
6667/tcp open irc

Nmap finished: 1 IP address (1 host up) scanned in 0.435 seconds

0

Oh sorry, I forgot that I had stopped the service, and edited the config file. I get this error when I try to restart httpd:

josh@server:/home/httpd/bin$ apachectl start
(13)Permission denied: make_sock: could not bind to address [::]:80
(13)Permission denied: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

I've got to go right now, but I believe I had just been trying to get it to work.. and editing the file viciously trying to get it to work.. I think I had it on: listen localhost:80.. but I'll post what it really says in like 2 hours.

0

Okay sorry, the real error message is:

root@server:/home/httpd/bin# apachectl start
(99)Cannot assign requested address: make_sock: could not bind to address 192.168.0.1:80
no listening sockets available, shutting down
Unable to open logs

And yes, I have googled and researched this problem myself before coming to the forums. Everyone else seemed to solve the problem by listening to any ip address at the specific port. This does not work for me..

192.168.0.1 is the address of my router.. however, it is properly configured to forward all http (port 80) traffic to the server. The server's ip on the LAN is 192.168.0.101.. Thanks for any further suggestions.

0

Okay, I resolved that issue (apparently I must have installed apache in two different locations or something.. the apache demean in /home/httpd/bin was actually executing a httpd.conf file in /etc/httpd for whatever reason... (I was editing the httpd.conf file in /home/httpd/conf) =(

Now I am able to actually start the httpd, HOWEVER I believe it is only accessible from my LAN. When I ping 'schulte.homelinux.com' from my lan it correctly identifies the ip, and has 0% packet loss. When I ping from outside the lan, then schulte.homelinux.com correctly resolves the correct ip, but the ping fails with 100% packet loss.

0

ping is ICMP and has nothing to do with http and port 80. try from outside to "telnet your.server.wan.ip 80"

anyhow, can you access the webpage from within the LAN? we have to locate the problem to either the router, or the httpd server

0

Okay, here are the results from accessing the webpage from the LAN:

Typing schulte.homelinux.com fails
Typing the public ip address fails

However, typing the private ip address of the server does pull up the "It Works!" apache default webpage.

so... does this mean there is something wrong with my router forwarding traffic to the http server? Or perhaps my isp? Maybe there is something I have done wrong in the configuration files..

0

well, if you can access the http server, you must have misconfigured port forwarding on your router. try to put the server's IP in the DMZ address in the router and see if that helps

0

I have port forwarding enabled property.. it's configured the same way for my ssh and irc servers (just with a different port).

The DMZ doesn't work either :-/

0

I am certain that it has nothing to do with my router.. is there any other config file or something that would be stopping traffic on port 80?

I edited my hosts file to contain the server's private ip followed by 'schulte.homelinux.com'.

0

as I said - if you can reach the webpage from the lan, but cannot reach it from outside - something is wrong with port forwarding

0

you might not have enough memory?

I know that MySQL says "cannot create socket" if you have under 256ram, and it intermittently refuses connections. Maybe the same thinking applies to apache?

0

Really? I only have 96MB of ram... and I know for a fact that port forwarding is properly configured..

0

after furrther thaught i dont think the memory matters much for apache as dont routers and stuff run it? they have like 4mb ram or something...

0

Hey, yeah.. sorry I thought I had closed this thread. The issue was resolved.. long ago. Apparently it was my ISP blocking port 80...

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.