Start New Discussion within our Mac OS X Community

I dont know if it happens to other people's mac but mine whenever i delete file or data from my flash drive with me mac it leaves exactly the same size of the same files i deleted in a .Trash, _DStore folder. plus how can i enable show/hidden files on mac OS X 10.4?? just like windows.

There should be an item on your menu bar at the top of your screen that says "Finder".

There should be a menu item under the Finder menu that says "Preferences".

There should be an "Advanced" item and under there should be a check box to "Show all file extensions".

With that selected, you should now be able to see the complete filename of all the files.

When you empty the trash, all files in all of the .Trash folders will be emptied.

I hope this helps -

Deleting files is a two step process. When you delete a file, it moves it to the trash. Then you must empty the trash. There is software that will empty the trash if it goes over a certain limit. Hazel comes to mind.

Mac's do that with external USB memory sticks - it's quite annoying to put it mildly.

The quick solution is to empty your trash, but if you have files in your trash that you're not sure you wish to delete. Another thing you can try is holding the 'ctrl' button while clicking on the drives icon, on the desktop. It may offer a format option.

Good luck!

I agree with the rest above. you can also go to finder preference by holding command , when you hold the two buttons the preference will appear and you can change the settings. you can also go disk utility and erase your thumb drive to get back the original memory. for example you have a 2 GB thumbdrive but now less 1GB. just go disk utility and click on your thumbdrive name. select the option erase and choose erase free space or erase. erase mean deleting all your files and the thumbdrive original space will be recovered. for example you erase a thumbdrive that has only 2 GB now but originally 8 GB. After erasing your thumbdrive, the thumbdrive memory will be back to 8 GB

Hope my above post helps. Anything just post, i will help you. Try following the other posters advice

If your problem is solved can you please mark the thread as solved. You can do that by going to the bottom. Thanks, i appreciate it.

I agree with the rest above. you can also go to finder preference by holding command , when you hold the two buttons the preference will appear and you can change the settings. you can also go disk utility and erase your thumb drive to get back the original memory. for example you have a 2 GB thumbdrive but now less 1GB. just go disk utility and click on your thumbdrive name. select the option erase and choose erase free space or erase. erase mean deleting all your files and the thumbdrive original space will be recovered. for example you erase a thumbdrive that has only 2 GB now but originally 8 GB. After erasing your thumbdrive, the thumbdrive memory will be back to 8 GB

Follow royng advise and go to disk utility. Select the thumb drive name and click on erase. The format should be mac os extended journaled click on erase to delete the item on your flash drive and get back the original space. Click on security options to change the erase setting, i recommend you to use zere out data. Hope it helps.

but if you don't know why put something that docent work you knpw who you are and that is not cool at all !some people relay need a good answer im not just saying me because I'm mad saying because it is true

Brilliant!!! My 64Gb flash drive only had 3 Gb of space available. I couldn't figure out what was wrong until I found this thread. I had used my drive to store my iPhoto library and trashed that huge file to make room for a file to transfer to my daughter. I had no idea it would remain in the flash drive trash. After reading this thread I plugged my flash drive into my computer and emptied the trash. Took a while to empty the trash as it was deleting my 60Gb iPhoto library file but I now have all my space back. Thank you, thank you, than you!!!!!

To only erase the hidden ._ files open the 'Terminal' app and presuming you are tyhe administrator or have permissions to change files type in

find /Volumes/<your-volume-name> -name ._* -type f delete

do not use italics, for some reason the print is automatically changing to italics on the end???
Safety note: Run that without -delete to see which files would be removed. And don't ever do this on your whole Mac HD, only on your USB drive.
If you run it without <-delete> all the ._ files should appear in Terminal. The first time I did this all the files showed up so I must have typed something wrong. Tried again and when I had only the ._ files showing I copied and pasted the command again and added <-delete> to it. All the ghost files were gone

This article has been dead for over six months. Start a new discussion instead.