0

Windows XP - Computer 1 & 2 - IBM Netvista ThinkCentre's P4; 2.8 GHz
Problem:
Computer 1 (Windows XP Home) copied photo's from 2gb SD card using Lexmark Pro200 printer with SD card reader to Easygo 4 GB flash drive (verified that the photo's were there.)

Computer 2 (Windows XP Pro)- when Easygo 4 GB USB flash drive is inserted:
Easygo 4 GB flash drive is recognized as Drive L:

  • When I try to open from My Computer a message pop's up: "Drive is not formatted. Do you want to format it now?"
  • when answer "no" - drive is not readable and the same message appears
  • when answer "yes" - tried to quick format - message: could not format
  • when answer "yes" - tried to format - went to end - deleted photographs and gave a message that could not format

The same errors occur when I put the SD Card(created by Cannon DC320)in the Dynex SD Card Reader/Writer (Drive M:).

The same errors occur when I put the SD Card(created by Cannon DC320)in the Lexmark Pro200 Printer Card Reader/Writer (Drive K:).

Computer 1 NO PROBLEM with any of the above (Lexmark Pro200 Printer Card Reader/Writer; Dynex SD Card Reader/Writer; Easygo 4 GB USB flash drive).

Never had a USB problem on either computer.

FYI...the SD Card has 1 Directory, 2 sub-directories that contain only JPG files.

Your help would be appreciated!

Thanks, THP

4
Contributors
40
Replies
44
Views
6 Years
Discussion Span
Last Post by flagstar
Featured Replies
  • 1

    **Solution finally found** The problem was identified when I ran Norton's Power Eraser - FastFat.sys Driver is Bad. A brief dexcription of steps to repair the problem: 1. Boot Windosw XP (using boot disk) in Repair Mode 2. Renamed the old driver C:\Windows\System32\Drivers FastFat.old 3. copied a new FastFat.sys driver … Read More

0

Flagstar - Thank you for you interest! I "attempted" to update the drivers for both card readers (Dynex and Lexmark Pro200). Message was that most current drivers we installed. The same is true with the USB Flash Drive.

All 3 devices were purchased within the last 2 weeks.

Could you tell me another way to update drivers?

All 3 work perfect on the other computer.

Thanks again Flagstar,
THP

0

Okay you could look for automated driver updater software so you won't have to search each drivers for a long time but I prefer finding it manually.

If you can, try to search for the specific model/product code for each card reader you own and post it here so that I can help you with your search.

We'll go further if you got the model code. If you can't find it, then look inside 'Device Manager' and check for installed card readers. It's model and version should be in there.

0

Thanks Flagstar for your continued help!

Infra is the list:

Dynex Mini DX-CRMN1 SD(among others) Card R/W;
Easygo 4 GB USB flash drive;
Lexmark Pro200 Printer has SD(among others) Card Reader/Writer and USB (same error on both

The only one that came with installation software was the Lexmark.

Thanks, thp

0

Lets dismiss the flash drive because it already has plug n play drivers installed and just focus on finding the other two card readers.

If the card reader was already built-in on your computer, this would be easier...
Use Lexmark software installation disc and install just driver utilities or even a program for SD card reader to run properly..

For Dynex Mini it was also a plug n play when I try to find it so pretty much your card reader is fine at this point.

If solution above does not solve the problem, run 'chkdsk' utilities under run command.

Type this below on Command Prompt windows

chkdsk X: /f /x /r

Note that X is drive letter so change it to the drive letter where your USB peripherals are inserted.

0

Flagstar, thank you for your continued support.

Before I run checkdisk to fix and repair disk errors, I'd like for you to help me step back and look at the overall problem.

1) All 3 devices work great on the other computer (so could it be a disk/card error)

2)The computer that has the problem: this is the 1st time that I've tried to read a USB Flash Drive or an SD card. Is there anything unique about those USB devices?

3) The computer that has the problem also has attached a USB Seagate FreeAgent 250 GB and uUSB Maxtor 320GB hard drives all of the time. I also attach a Seagate 1 TB drive occasionally for backup. I also occasionally attach a 80GB USB 1.1 drive for coping info to/from old IBM Thinkpad R42. All have worked perfectly.

Bigger Question: Is there something unique about the 3 new devices that could create the problem we're seeing?

I'm certainly at a loss, thank you again for your ideas and support!

Thanks, thp

0

checkdisk utilities won't delete your personal files, it just scan for any errors in Windows or partition and correct it automatically for you.

1- If the device work fine on other computer, then there's something on the problem computer that create such error.

2- Most USB devices have their own driver and they don't need to install anything. Plug and play means you just attach it, it'll install the drivers automatically and you can access it.

3- Well it shouldn't be a problem when those USB HDD were attached for a long time now and if they can connect then it also means your USB port is also fine. But for troubleshooting, might as well try to plug out all other USB peripherals so they won't get in the way during testing.

BQ- Like I said before, there could be something that blocked your access to newly attached USB devices like your Card Reader.

Apart from the 3 USB devices, do you have any other flash drive to test? I mean just borrow some friends flash drive and plug in to your problematic computer. If that also fail then there's something wrong with Windows...

0

Thanks again Flagstar!

I've removed all usb drives; Removed the drive letters; disconnected power; restarted and the same problem occurs..."do you want to format?"

I'll purchase another Flash drive next week and let you know what happens.

Is there a difference in XP Home SP3 and XP Professional SP3 (problem on this computer) that could be the difference?

Thanks again for your support!

thp

0

Flagstar and all - Latest in this saga:
Attached the 3 USB devices to my IBM Thinkpad R40 and they all work perfectly. The Thinkpad is running XP Professional SP3...so I guess that eliminates the concern over the differenc in Home and Pro.

Purchased an new 4GB Scandisk Flash Drive. Same problem as the other 3 usb devices on Computer 1...identifies it as Drive L:
Used Space 0 Bytes
Free Space 0 Bytes
File System: RAW

Placed the same newly Purchased an new 4GB Scandisk Flash Drive in the Thinkpad R40. Identifies it as Drive E, installs "software to make new drive work and reboots and works perfectly.
Used Space 40,000,000 Bytes (approximately)
Free Space 3,960,000 Bytes (approximately)
File System: FAT32

Remove the drive after shutting down the R40 and install in Computer 1...identifies it as Drive L:
Used Space 0 Bytes
Free Space 0 Bytes
File System: RAW

I have not written or formatted this new drive.

Do you have any suggestions?

Thanks,
THP

0

After seeing this. Probably your USB port does not work properly anymore even though it can probably detect your external HDD just fine.

This is the last test and if this fails, there'll be two possible options. Reformat or buy a PCI USB.

Have you actually try all USB ports? I don't want to miss any points that can be very important later on. If you have try this on front panel USB only all the time, this time plug your USB devices at the USB post behind the desktop.

Actually there is some problem between Home and Pro but not very much significant and USB problems aren't on the list. The only difference is Home is not as powerful as Pro...

0

Flagstar, thanks again for your support!

After reading your post, I have now tried all of the USB Ports....same result.

I did try to format the new Scandisk Flash drive using Disk Management...format would not work using quick format or standard standard.

On computer 1...Drive is healthy and identified as Scandisk Cruzer in USB properties menu but as drive L: in my computer....again: 0 bytes used 0 bytes Free File System: RAW

Have not thought about a PCI USB, how would the system view it differently?

Flagstar, Thanks again, thp

0

PCI USB is an external PCI card that can be attached inside your computer for extra USB port. Usually you can find one with 4 extra USB port although it's not necessary to have so many USB port. You can find it at local computer store nearby for a cheap price. Usually it would cost about $10 only.

The same thing happen to my computer as well just recently but most flash drive were good anyway, only external HDD can't be detected for some reason. I also tried with Linux system but surely it won't detect my HDD.

Of course formatting RAW flash drive with 0 bytes will come out nothing anyway so it always fail if it won't able to read flash drives properly...

EDIT: Oh I was too stupid I didn't realize that you can actually detect your flash drive but it won't read properly. Okay, put on hold for buying new PCI USB for now and just stick with windows system. If windows was able to recognize it, then your USB port wasn't the problem one after all. It was Windows problem...

Ok next test, hope you can bear for more time as I try to solve the problem you're having now...

Reboot your computer and when BIOS screen appear (the one with many white texts), tap F8 continuously till it got into a menu for safe mode and other options. Enter Safe Mode. (You can attach a flash drive while it still booting) Do a test with your USB flash drive...

Edited by flagstar: I'm so stupid didn't highlight the main problem...

0

Flagstar...Thank You for your continued support!

Stupid...You are NOT! I think you are on the right path....It's windows.

As per your suggestion, I rebooted in Safe Mode and signed on as Administrator. The problem is the same: Healthy device - 0 used space - 0 free space - 0 capacity

I have also tried to compare settings/drivers/etc. with my Thinkpad R40 (Also XP-Pro on which the devices work) and I don't see a difference.

The problem only occurs on Flash & SD card devices. The Lexmark Pro 200 printer that has both readers has the problem when devices are inserted but prints, scans and fax's without a problem.

(sorry it took me so long to followup - was out of town yesterday)

Thanks again for your support,
thp

0

FYI - when I booted in Safe Mode, the following was displayed at the top of the screen:
MICROSOFT(R) WINDOWS XP(R) BUILD2600.xpsp_sp3_gdr 101209-1647: service pack3)

It's as though some setting is blocking data access for this type of device.

0

The Microsoft message were not that important. It just show what windows you're using and usually appear in safe mode. Yours using xp sp3 so it's the latest and final xp you can get.

I guess you have a point there since services and drivers weren't the culprit. It's proven from safe mode which disable all services and use only default xp drivers.

It must be some programs conflicting that create this mess somehow. Download DDS scan from HERE and run it. Afterwards it'll create two logs, DDS.txt and attach.txt. Copy paste both content here.

And this is optional, just to clarify windows is the one making a mess. Download Puppy Linux from HERE and once done, burn it as CD. (This is on .iso format so you can just double click the downloaded files and windows will burn it for you)

Step 1: - Insert cd to your computer that has problem.
Step 2: - Reboot your computer
Step 3: - When boot screen show up, quickly press Del button. It should enter BIOS
Step 4: - Under Advance Setting, enter Boot Priority and let CD-Rom boot first
Step 5: - Save and quit BIOS
Step 6: - It should now boot Puppy Linux by itself. Wait till Puppy Linux windows show up
Step 7: - On bottom left, there should be a storage peripheral icon. Plug your usb devices
Step 8: - If the usb icon shows up, double click the icon. Verify if the usb can read it's content or not.

****This is just optional so if you don't know how to do it, it's fine to skip it. This was just to validate that your windows is the culprit...

0

Flagstar, thank you again for you advice and wisdom!

Just an update...I downloaded DDS.scr as requested. When I try to execute, it goes into command mode displays a message and starts scanning...after 54 # signs the computer is locked.

The message mentioned "script blocking tools" so I disabled Norton 360. and executed. Again...after 54 # signs the computer is locked.

Any suggestions, I'm downloading Linux puppy (this ought to be fun)

Just wanted to let you know what's going on.

Thanks, thp

0

Flagstar - Latest update.

Still can't run dds.scr without computer freezing up after 54 # signs.

Puppy Linux - downloaded and burned CD (windows used RecordNow)

Questions:

What is the difference in pressing F8 while starting and
"Step 3: - When boot screen show up, quickly press Del button. It should enter BIOS"

Where is the boot screen? I have 2 screens that display (tried to press delete during both with the first screen - it locks the computer...in the second - computer ignores.

1st screen: "IBM system is starting. (to interrupt normal startup, press Enter)"
2nd screen: "Initializing Boot Agent..." (when pressing delete here, it's totally ignored)

Thanks again, thp

0

Flagstar, You are terrific!

Computer 1 (our problem computer)Puppy Linux runs GREAT!

USB & SD Card reader on the Lexmark Pro200 printer read SD Card and USB Scandisk Cruzer Flash Drive without a problem...even though the Printer has not been installed in Linux.

USB Scandisk Cruzer Flash Drive works great when plugged directly into any USB Port.

Dynex DS Card R/W works Great!

As you thought, "It must be some programs conflicting that create this mess somehow." the problem is WINDOWS XP.

I still can't get DDS.scr to run without freezing the computer. Is there another program I could be running that is a "script blocking tool"? I took screen images using Jing of "startup"...but don't know how to post or if that would be helpful.

Thank You again, thp

First thank you for isolating the problem.

0

Sorry for being absent for a while. I always unavailable on mondays so seeing you replies this much I feel I have ignored you out.

But on the positive side, congrats that you managed to run all USB devices on Puppy Linux and thus pinpoint the exact problem. The only thing to correct is your Windows.

It's strange for DDS.scr though. It would come out Command Prompt and it would come out with text like this

"DDS scan now running on silent. DDS will produce two logs for you after system scan is done"

^ I just wrote this from my brain memories so it would be different from real message but it should be similar.

But if it come out as 54# signs, use HJT tools next. It was not as powerful as DS but it should bypass any error it encounter.

For screenshot, it's okay to upload it somewhere (except imageshack) and post the link here. I'll view it from there.

Edited by flagstar: n/a

0

Flagstar, I appreciate all of your advice in isolating the problem. Don't be concerned about Monday...I used the time and multiple replies to work on the last post you made.

Let me clarify about dds.scr.....Your memory is correct, it did come out Command Prompt and it would come out with text like this "DDS scan now running on silent. DDS will produce two logs for you after system scan is done" The # signs are posted at the bottom of the screen a the dds.scr scan progresses. The system always freezes after ####### appears 54 times at the bottom of the screen. This morning I even tried to run dds in SAFE MODE...again the computer froze...only way out is to power off.

I did run Hijack This and the results are attached in a PDF file using the Advanced editor. Please let me know if you cannot read it or find it. No Boxes were checked. (FYI, I have a 08/2008 log from HJT I can post if you think it might be helpful)

Thank you again for your support, thp

0

From your HJT report, it seems you have installed a lot of unnecessary toolbar that wasn't needed like Iobit, Yahoo, Google, Ask etc. . Remove and uninstall them so toolbar apps won't get in the way. Some toolbars blocks how computer normally works on some occasion.

And type in 'msconfig' under run. Click on startup tab. Disable all startup programs except the one from system32 folders.

Also uninstall Flashget3 for a while, you can install back after this when the problem is solved.

I couldn't identify that this is from virus attacks either. Just to be on the safe side, if problem still won't solve, download Malwarebytes Anti-Malware and install them on your computer. Update the software and run full scan after update is complete.

If it indeed found viruses, I'll redirect you to another forum and let some volunteers help you remove other unwanted malware and stuff.

All the best.

Edited by flagstar: wrong links

0

Flagstar, Thanks again for all of your support.

Sorry to hear about your USB. Do you still have a problem?

I changed startup as requested...same problem with Flash.

Do I need to do toolbars because i have the problem when I start in Safe mode without networking.

Downloading malware now...will let you know tomorrow.

Thanks, thp

0

My USB?? Do you refer to mine or other poster?

Most of the time user doesn't use toolbar. It was just a waste of browser space and hogging down your computer. You'll notice the difference when you have no toolbar and with toolbar.

If you still use it and you think it's important, then just leave it but I think that could be the reason why your computer have problem. If you refer to someone in spyware forums, they would definitely advice you to remove those toolbars.

0

Flagstar, thank you for your guidance and expertise.

My USB?? Do you refer to mine or other poster? - my bad - don't like to see anyone with problem - didn't notice that there was another poster (hope rajaloeck finds a solution)

Update:

  1. removed all toolbars & changed startup to remove all except system32 items (missed one google startup) - attached is new HJT Log
  2. was finally able to get dds.scr to run (after Startup changed - before toolbars removed) log file is attached
  3. still having the same problem with ScanDisk Flash drive L: - attached 2 images so you can see

dds.scr again will not run without locking computer

Ran Malwarebytes - it only identified adware and registry stuff from MYWEBSEARCH and WEBENHANCEMENTS that Norton's had found and I had not removed because I uses from time to time.

FYI - I rarely use Internet Explorer - always use Chrome and Firefox.

I hope this is not to much information / confusing. I just thought it was important for you to see what I see as much as possible.

Again, I thank you for your time and support.
thp

Edited by thp: n/a

0

From your DDS log, I didn't found any programs that might conflict with USB reading... Possible rootkit infection but I've to pass that too. And I found out that you have other problems besides USB reading error which may not be that much problem for you.

Sorry but I'm already out of ideas for solving this problem now. This could be the last solution for you from me but care to ask other members if they got best solution out. If not, a clean install is the best one although we like to put it as last resort.

XP security update 1 HERE

Update 2 HERE

Update 3 HERE

Another way is remove sp3 update and go back to sp2 but if you do this, you won't be able to receive security updates from Microsoft since they have stop supporting sp2.

I'll research this a bit more for you. I'll post the possible solution when I got at least one or two...

0

i would take it to a computer it works on if it does work on other computers, take the file off it and format it and start a new .then see if it works on your computer fine if not ,
this may have already been covered ,but what happens if you unplug all external usb devices ,go to device manager and uninstall all usb devices ,reboot windows to reinstall them ,then try the faulty device before adding any of the other usb devices

Edited by caperjack: n/a

0

Flagstar, Thank You for your continued support.

At this point, I have downloaded all of the security updates as per your request, but not proceeded because I want to make sure that I do this right...Just install 1, then 2, then 3 without uninstalling sp3. Is that correct?

I'm not sure that I want to uninstall SP3 unless you are sure that it will fix the problem, I think would rather use your Puppy Linux solution when I need the SD and /or Flash Drive.

Caperjack, I Welcome your input and skills! Thank you for taking the time to real all that has been don and thos things that Flagstar has help me eliminate.

I have purchased another new Scandisk Flash Drive and another SD Card....same error. I formatted both on the Thinkpad...still don't work. I tried to format both on the problem computer...they will not format.

Caperjack, as you noticed, I did remove all USB Devices and reboot - same error (even in safe mode even as Administrator), but I had not removed using Device Manager. Jut did as you suggested...same problems with the FAT32 file devices (Flash Drive and SD Card). In addition to all of the USB Hard Drives that had been attached, I added an new one that we had purchased, but never used, for the computer 2 (500 GB GoFlex Drive). It works Great.

It seams like I can add all of the NTFS Hard Drives I want without a problem.

The problem always occurs with FAT32 File System Flash Drives & SD Cards.

Could there be a configuration error in windows?

Flagstar and Caperjack, You will never know just how much I appreciate your interest and expertise!

Thanks, thp

0

The problem always occurs with FAT32 File System Flash Drives & SD Cards

so did you try formatting it ntfs ,although i don't think it will matter ,but cant hurt to try ,

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.