Have new iMac w/ OS 10.6.6. Installed older version of Excel (2004). Worked fine. Opened files, worked on them, no problem. There are 5 files, though that won't open. Tried double-clicking and get a "flash" of the loading bar but nothing opens. Went to menu bar: File, Open, find file name, etc. The thumbnail shows the file w/ data in it but it will not open it.

I copied the file to a jump drive, took it the old G4 PowerMac and the file opens! So the file seems to be fine.

The file is one which I update every year. At the end of the year I do Save As, and in the newly created copy, change the year in the title and delete the cell contents. Basically use the same file from year to year.

Files up to and including year 2004, open fine. Years 2005-2010 do not open. However there are other unrelated spreadsheets that were created in 2010 that open just fine.

It's a mystery to me. Not sure if OS conflict w/ older version of Excel - but then why would it work for some files and not others.

It seems to be only these 5 files which are affected.

Would reinstalling the Excel software possibly correct it? Or make it worse?

Any ideas would be greatly appreciated.

Thank you!!!

Recommended Answers

All 2 Replies

Reinstalling will sole it.

Thank you! Should I Uninstall first, since some updates were downloaded after I installed it from the disks?

If I should uninstall, could you please tell me if it is possible to uninstall only the Excel portion? So far I can only find instructions on how to uninstall Office 2004 as a package, and not just the Excel portion.

Thanks again.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, learning, and sharing knowledge.