On the advice of a friend and long time Apple/Mac user I installed a utility called Macaroni. All the maintainance "jobs" ran fine. Repair Permissions is included in Macaroni. When I ran that it stalled, never finished. Also, could not stop it or force quit. Had to turn machine off. Restarted OK. Tried to run Repair Permissions under Disc Utility, same results.

Support from AtomicBird/Macaroni was no help.

Have uninstalled Macaroni, still have same problem. Not able to repair permissions. It starts, just never finishes, and the only thing I can do is turn computer off. Everything else seems to run fine.

Anyone have any suggestions?

OS X 10.3.9
G4 1.25 GHz.

Recommended Answers

All 7 Replies

Open Terminal.app, type in:

sudo diskutil repairpermissions /

And then post the output. It may take a while to finish. Where is it dying? It should not be freezing your Mac to the point where you have to force quit or force restart.

Sorry for delay. Last 2 days have been hectic. Anyway...
Here is what you requested. How is this helpful?

Last login: Wed Nov 23 10:11:36 on console
Welcome to Darwin!
V_Ws-Computer:~ vw$ sudo diskutil repairpermissions/
Disk Utility Tool ?2002-2003, Apple Computer, Inc.
Utility to manage disks and volumes.
Most options require root access to the device

Usage: diskutil <verb> <options>
<verb> is one of the following:
list (List the partitions of a disk)
information | info (Get information on a disk or volume)

unmount (Unmount a single volume)
unmountDisk (Unmount an entire disk (all volumes))
eject (Eject a disk)
mount (Mount a single volume)
mountDisk (Mount an entire disk (all mountable volumes))
rename (Rename a volume)

enableJournal (Enable HFS+ journaling on a mounted HFS+ volume)
disableJournal (Disable HFS+ journaling on a mounted HFS+ volume)

verifyDisk (Verify the structure of a volume)
repairDisk (Repair the structure of a volume)

verifyPermissions (Verify the permissions of a volume)
repairPermissions (Repair the permissions of a volume)
repairOS9Permissions (Repair the permissions for the current
Classic boot volume)

eraseDisk (Erase an existing disk, removing all volumes)
eraseVolume (Erase an existing volume)
eraseOptical (Erase an optical media (CD/RW, DVD/RW, etc.))
zeroDisk (Erase a disk, writing zeros to the media)
randomDisk (Erase a disk, writing random data to the media)

partitionDisk ((re)Partition a disk, removing all volumes)

createRAID (Create a RAID set on multiple disks)
destroyRAID (Destroy an existing RAID set)
checkRAID (Check a RAID set for errors)
enableRAID (Convert a disk to a degraded RAID mirror set)
repairMirror (Repair a damaged RAID mirror set)

diskutil <verb> with no options will provide help on that verb

V_Ws-Computer:~ vw$

Yeah.. wrong syntax.. there's a space between the "repairpermissions" and the "/". So, what you did wasn't helpful. When it's entered correctly, it's the same as repairing permissions via the GUIfied Disk Utility, but without the crash/freeze/whatever is happening to you.. plus the text output (when entered properly) will tell us where the repair permissions is failing. Hopefully.

So, to recap:


I am free today, lots of time to work on this. Figured it would be awhile before I heard from you, so I did what I probably should have done to start with. Am new to Mac though so was hesitant to do something I did not understand.

Booted to install disc, then disc utility > verify disc. Lots of errors/missing data found. Ended with "volume needs to be repaired." Ran disc repair. Lots of repairs noted. Ended with "one volume repaired" followed by "one volume could not be repaired", in red. I was not happy. Ran verify disc again, fewer probs. noted. Ran repair disc again. Went pretty quickly but ended the same, one volume repaired, one volume not repaired. Was definantly PO'd.

Booted to HD, went directly to disc utility. Verify permissions went quickly. Ran repair permissions. It took about 5 min. but did finish. Seems to be OK now.

Did follow your new instruction for terminal (after above). Report was:

ppp-69-208-157-135:~ **$ sudo diskutil repairpermissions /
Started verify/repair permissions on disk disk0s3 Macintosh HD
Determining correct file permissions.
: object: ./Applications/iTunes.app/Contents/MacOS/iTunes malformed object (inconsistant sizeofcmds field in mach header)

We are using special permissions for the file or directory ./Library/ColorSync/Profiles/Displays. New permissions are 16893
We are using special permissions for the file or directory ./Library/ColorSync/Profiles. New permissions are 16893
We are using special permissions for the file or directory ./System/Library/Filesystems/cd9660.fs/cd9660.util. New permissions are 33261
We are using a special uid for the file or directory ./private/var/at/jobs. New uid is 1
We are using a special uid for the file or directory ./private/var/at/spool. New uid is 1
The privileges have been verified or repaired on the selected volume
Verify/repair finished permissions on disk disk0s3 Macintosh HD


1 The notation in terminal about iTunes is worrisome. I believe the last last update I received was for iTunes. That was a week or two before this "problem" started. What do I need to do to correct?

2 Why the notation about 2 volumes, one repaired - one not repaired. Do not understand this.

3 Would it be a good idea to occassionaly run a "maintainance" disc repair, or wait till problems occur?

Thanks for all your help,

1) This is the 2nd time I've seen this in this forum.. I'm wondering how/why. It's in this post: HERE I don't see this error on any of my boxes.. Since this is associated with a permissions repair it maybe just a malformed BOM in the /Library/Receipts/iTunes.pkg (or iTunesX.pkg?). How to recover from this? I'm not 100% ATM. You might want to Google before doing anything I suggest. Personally I'd start by ditching the iTunes and iTunesX packages in that directory and redownloading/reinstalling iTunes. Though you might have to do a bit more a drastic removal of all things iTunes to recover.

2) This would definitely worry me as well. You might want to invest in a real disk repair software like Disk Warrior or Tech Tool Pro. Apple's Disk Utility repair is only good for the most minor of problems. Anything serious should be handled by one of the above.

3) I don't really see the need for this.. but you certainly don't hurt anything by keeping an eye on how everything is running, particularly the SMART status of your hard drive.

(from your link to the other post)
Permissions differ on ./usr/share/man/man1/less.1, should be -rw-r--r-- , they are -r--r--r--
Permissions differ on ./usr/share/man/man1/more.1, should be -r--r--r-- , they are -rw-r--r--

I remember seeing the same after I removed Macaroni and tried to repair permissions (before it stalled).

Checked my installed update log. iTunes was the last update. On 10/13, update 6.0. On 10/27, update 6.0.1. Maybe we're on to something here?

When I bought this Mac a year ago at the local Apple Store, also purchased the extended protection plan and received a CD with no explanation what it was. It was months before I realized there was a copy of TechTool Deluxe on it. Never installed it. Guess I will have to learn how to use it.

A restore/re-install SHOULD solve the problems? I mean as a final option.

Tech Tool Deluxe and TTPro are not the same thing.. basically what you got there with AppleCare was a hardware test CD. A complete erase (zero all data) of the hard drive and a reinstall would/should take care of that, but I think that's a last, last, last resort. (obligatory: don't forget to back up all your data)

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.