Hello ;)

Having trouble with my silver powerbook running OS X...on starting i get a folder with a flashing question mark on it. I haven't the boot disk needed to load my desktop so that i can then 'bless' the system folder. Have borrowed an installation disk which when i load up at start takes me round in circles only to tell me eventually that the disk cannot be used for my system. Please can somebody help.

Would ideally like to visit a mac expert local to NW2 London as have tried what i thought was the solution but have gotten nowhere fast. There might be something else i am not doing with the installation disk but haven't a clue what to do - a pro would know am sure.

I am skilled in designing and making things from clothes to artwork and so would be only to happy to repay any help I can get.

Thanks for reading.


There are about 10 of us from the UK here so someone aught to be able to help you. Im not a mac guy, myself but i think that maybe that symbol means a dead/corrupted filesystem and the reason your borrowed install disc wont work is possibly because its for an intel mac, and you have a powerpc, or vice versa.

Try pressing the option key. You should get a list of available "System Folders". If you don't, I'd say running either Disk First Aid or similar to fix it.

Member Avatar for BobTheLob

What I'd try to do is call apple support, tell them what is wrong, and if possible get an installation disk from them for that computer. once you have the disk, do a clean re-install. that will delete anything you had before on your hard-drive (like a corrupted file) and re-install the OS. if you want to try to save files from before, do the archive install. i'm still somewhat new to the Mac, i've had it for about half a year now, but i'm computer savvy.

I would definitely try running a disk utility of some kind, that sounds like there's a corruption. But, I'm not in the UK so I'm not sure of any further specifics...

How old is the comp?

Thank you all!

Am extremely reluctant to take any of the steps you have advised for fear of inadvertently deleting files stored. Really need to visit a mac pro if possible...am in NW2 London but get about a bit ;)



I am based in CM21, a little distance for you unfortunately but I will try to help as much as I can.

The only solution to your problem will be to use a Power PC OS X Install CD for your version of OS10.
Holding the option key as said before, you can get a screen showing the bootable devices linked to your machine (CD, External Hard Drives etc.), (you can also hold the 'C' key on power to boot directly to the CD). once a correct install DVD/CD is found you can run Disk Utility from inside the actual installer itself from the Utilities drop down menu at the top of the screen, without any risk of losing your information. If this does not work you can also try an 'Archive and Install', you will not lose your information this way either.

If Disk Utility does not solve your corrupt operating system files, it is possible to run Disk First Aid as described before in this post.

If none of this has worked and a re-installation is required, then you can always turn your Powerbook on holding down the 'T' key on the keyboard to put it into Target Disk mode, then once the Firewire symbol comes up on the screen you can plug it into another mac and copy off your information as if it were an external hard drive.

Hope there is something there that can help in some way.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.