0

I posted this originally at the MSDN forums, but wasn't able to get any help. Visual Studio FTP doesn't work on my desktop (which has XP), but the problem is only on my desktop.

I can create and delete folders and files via FTP but I can't open files. Trying to open a file via FTP gives an "Unable to get file 'filename.ext' from the Web server." error box. If I make a file through VS itself I can open it, but not save any changes. If I close the solution or close VS, then I am unable to open those files now as well.

Things I've tried, and other details:

  • I tried connecting to multiple FTP servers, and tried setting file permissions to 777.
  • All other FTP programs I use on this computer, including Dreamweaver, work fine.
  • Unchecking passive mode does not fix the problem.
  • Using Windows safe mode doesn't fix the problem.
  • I've run anti-virus and anti-spyware software.
  • I thought maybe it was Windows firewall, but I looked and that was already off.
  • My desktop's default FTP software was Core FTP; I thought maybe that was interfering somehow, but I uninstalled that and it didn't fix the errors in VS.
  • Someone else had the same problem, but their solution of File->Open Web Site gives me the same error, 'Unable to get file ... from server'.
  • My original problem was with Visual Studio 2008. I tried repairing and unstinalling/reinstalling. I even tried installing the Visual Studio 2005 trial, but encountered the same problems with that.
  • Most strangely, installing Visual Studio from the same 2008 DVD (as well as the 2005 trial) works fine on my laptop (which has Vista), which is on the same wireless network as my desktop. I also moved my desktop's ethernet cable to the laptop so that the connection was exactly the same; the laptop's VS FTP still worked fine. So it's not a network issue. It's some problem specific to my desktop.

What sort of setting might be causing this? It has to be something wrong with my desktop, but I have no idea what could be interfering with Visual Studio's FTP functionality, and yet leave the FTP functionality of other FTP software like Core FTP and Dreamweaver, both of which I use all the time, unaffected.

3
Contributors
3
Replies
5
Views
9 Years
Discussion Span
Last Post by gigrada
0

I have been trying to figure out how to fix this exact same problem, so how did you fix yours?
The weird thing is that Dreamweaver works for the same Website?!

0

I had the same problem (although I was using Frontpage Extensions to connect instead of FTP).
The problem seems to be caused by the corruption or deletion of part of (but not all of) Visual Web Developer's cache files.
Here is how I fixed it:

  • From Visual Web Developer, try to save a file into into one of the folders where you can't open a file. The error message that pops up will contain the path of the temp folder.
  • Most likely the folder will be something like: c:\Documents And Settings\User\Local Settings\Temp\...
  • I deleted everything inside that Temp folder (you may have to close down all your apps to do so - Firefox, IE, etc.). Likely you only have to delete the VWDWebCache folder that resides inside that temp folder.
  • Once you've deleted the folder, restart VWD and it will rebuild the VWDWebCache folder and
  • Voila! You can open your files again.
This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.