0

Hello,
I have a small form factor gaming PC with the following hardware.
MSI X170I Gaming Pro AC mini iTX MB
Intel i7 6700K CPU
32GBs GSkil DDR4 ram
Nvidia GeForce 1080 Founders edition GPU
OS Windows 10 Pro

I subscribe to Frontier FIOS (formaly was Verizon) for my hi speed internet. I have 75mb down and 75mb up.
When doing an internet speed check I routinely get around 82 to 88 mbs down however it struggles to even get 20 mbs up, these speeds are the same regardless of if on a wired Ethernet or WiFi. Both the Ethernet and the WiFi chips are Intel
When booting into a Mint Linux live pen drive I run the same speed check ookla using Fire Fox web browser and I got 85mbs down and 90mbs up. Also when check the speeds when running Windows 10 I ran speed checks on both my Nvidia Shield Tablet and my Note 4 phone both running Android 6 and get very similar speeds as my gaming PC running Linux going through the same router as the PC. Oh also on a side note I put a Windows 7 HD into this PC (I had made a backup image before upgrading to Windows 10) and my up and down speeds are what I should be getting.
Does anyone have any ideas of what the hell is going on with Windows 10? I have turned off all of their update P TO P file sharing. Is there something going on with the wrong informating in the registry?
Any assistance would be greatly appreciated.
Robert

3
Contributors
4
Replies
10
Views
5 Months
Discussion Span
Last Post by rproffitt
0

Please note that most internet connections have a higher download than upload speed because most users consume (download) more data than they create (upload). Having said that, rproffitt's suggestion is quite likely the culprit.

Edited by Reverend Jim

0

I have that setting turned off in Windows 10, right after doing a speed check in Windows 10 all my other os's and all of my mobile devices using the same internet connection get 80+mb/s both up and down speeds.

0

The clue as to what it is, is not in your post. I will write I've traced this to drivers most of the time with overreaching security suites next in line. I have yet to trace it to W10 itself. Unless that setting I noted is on.

Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.