0

hi. i've put an intel pro/1000 MT desktop NIC in an old xp home pc (p4, 2.6G Elitegroup p4vxad m/b). it connects fine at 100Mbps but when selecting 1Gbps it trys to connect and fails saying cable unplugged. initially it would crash the pc (sometimes). I've swapped slots twice (and ensured a different irq), deleted old hidden/removed NICs from 'devices', updated and backdated drivers, removed and re-installed it, tried it connecting thru a switch and directly to an xp pro machine and a freebsd machine, swapped 4 pair cables.

while it could be the card or a weird hardware clash, i'm hoping someone can suggest some way forward. the driver has lots of options of which i understand few... perhaps if i changed some settings it may help, but i don't understand what most of them are. settings include:
'adaptive interframe spacing', 'enable pme', 'flow control', interupt moderation rate', offload recieve and transmit ip and tcp checksums, 'QoS packet tagging' , recieve + transmit descriptors, wait on line and some otherbacis settings i understand. all are set to default.
can anyone who understand these things advise or suggest anything to try?

Thanks!

2
Contributors
3
Replies
4
Views
8 Years
Discussion Span
Last Post by mcbmcb0
0

p.s. - i should have mentioned that the card works fine on another (xp pro) machine.

0

Are you sure the cable supports 1Gbps and if you are thinking that having a connection speed of 1Gbps will speed up the internet connection it won't (for a home connection).

Are you part of a network?

I doubt your internet connection will be above 1ooMbps so I don't think there is any point worrying about it as you can't utilize the extra speed anyway.

0

the cable is fine - 4 pair. connects at 1Gbps on other PCs. and I've tried other cables.
The connection is to a switch with others PCs and a network storage box. I know my internet will remain at dsl speed.

I've since put in a cheap realtek 8169 based nic and that connects at 1Gbps and gives significantly highter transfer speeds. But I'd still like to get the Intel NIC working as at 100Mbps it is 15% faster (on my setup) than cheap 100Mbps NICs. I've messed around with the various parameters but with no success. Next step may be a reinstall of xp:icon_sad:
Other ideas appreciated

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.