0

This is strange to me, hopefully not strange to you guys:

I got my wife's desktop out of storage and brought it up - no connection to the internet. What's more, it's flaky - I've gotten it to talk a couple of times and then lose the connection.

I'm running W2K pro and connect through a Linksys Wireless G router (through a cable connection, not wireless) to a roadrunner modem. I have two computers on the net in addition to the one I'm trying to add - one is wireless and the other cabled.

I suspected the system itself and because I didn't care about this particular system and had an extra computer, I changed the hard drive and reloaded windows just to make sure it wasn't in software. Then, as I suspected the ethernet card I replaced it. I then replaced the cable. All one at a time. No dice.

When I replaced the card, I had a connection for a short while, which also happened when I connected the computer the first time (coincidence?). But I had no chance to check IP or anything else much. I went on the internet and even checked for the other computers on the net and got them. When I rebooted the computer, I had no connection.

When I disable the connection and enable, the desktop icon says I have a connection for a moment, then says the cable is disconnected. But I know the cable is good because I can connect it to the working cabled computer and it works fine.

Nothing I do will get that connection back. Like I said, I had the same process happen before I changed the nic, so it doesn't seem to be that.

Some additional info:

Before I changed the nic I connected directly to the cable modem and got a connection. When I changed back to the router, I continued to have a connection but no internet and couldn't see the rest of the net. After I changed nics I can still get a connection while connected directly to the cable modem but it doesn't stay when I reconnect to the router. FYI, I can't get to the internet when I connect the one cabled computer on the net directly to the cable modem either, but when I reconnect it to the router the internet is instantly available.

I have everything on DHCP. No special settings that I know of on any of the three computers.

I know about ipconfig and ping but can't remember just how to use them and find out what is going on. For example, I don't remember how to get the IP of the router or modem so I can try to ping them. However, without the connection, I guess it wouldn't do any good anyhow. Can't think of any more info to include...

Thanks in advance for any help you can give me...

zeroth

4
Contributors
12
Replies
13
Views
12 Years
Discussion Span
Last Post by UKno0bSter
0

I'll take a stab at this one.

1. Re-verify that your computer is set to obtain ip address automatically

2. start>run type cmd to get to a command prompt

3. At the prompt type ipconfig /all
That will give you the current ip address of that computer. It should be a 192.168.1.x. If it is a 169.254.x.x then you are not receiving a ip from the DHCP server. The ip listed for default gateway should be the ip of your router. Most linksys routers are 192.168.1.1

4. Next, find out if your computer can talk to the router. At the command prompt type ping 192.168.1.1(or the ip address of router if it is different) See if you get a reply.


Try out those steps and see what comes up.

0

thanks for the reply - since there is not a connection according to the icon, there is no way to get an IP address. I just connected direct to the modem and the IP is zeros.

I wanted to answer this right away so now I'm going to start playing with the other computers on the net and see what happens when I connect them direct to the modem, just for fun. Thing is, I'm only supposed to have one computer hooked to this modem, so it should connect right up...no?

btw, when I had the original nic in the computer it had an IP of 169.254.127.232 and the subnet was 255.255.0.0 That subnet IP seems weird, no?

I'll be back with more info after I try a few things...

thanks,
zeroth

0

OK, see if this helps...

plugged the cabled computer direct to modem and got an autoconfig IP as 169.254.210.80 I assumed that was the router and pinged it and got a normal response, I think...

plugged it back into the router and got the normal IP address, etc. - this may be useful - node type is mixed and IP routing enabled yes - I'll give you the new computer momentarily.

As I said, I don't get a connection on the new computer while connected to the router, when I go direct to modem I got (and this is strange) a bunch of zeros. Then tried the router again and not connection, then direct to modem again and then got the modem IP. Node type is Broadcast and IP routing enabled is NO. That seems odd. But getting zeros one time and modem IP the other is par for what I have been observing all day.

Man, oh man, this thing is driving me nuts. While I'm waiting on response, I'm going to go back over the entire setup on the new computer but I have already done this 1000 times today.

thanks,
zeroth

0

I'm a little confused on a few things, first let me make sure I'm looking at the correct router:

Linksys wireless G

For clarity purposes:
CompA = new computer
CompB = other wired computer

With compb, you said you got a normal ip when plugged into the router. What is the normal ip? It should be 192.168.1.x The value of x will depend on what the dhcp server gives it. The 169 ip address you received when plugged directly into the modem is not the modem ip address but the ip of that computer. When it cannot obtain an ip address from DHCP, it obtains a 169.254.x.x ip address. This is a private ip address that cannot be used to access the internet. If that comes up try the follow commands at a command prompt:

ipconfig /release
ipconfig /renew

and see what ip that gives you.

Assuming that is the correct router I listed above, the ip of the router will be 192.168.1.1 When you try to ping the router, ping that ip.

For CompA, when you are directly connected to the modem and get an ip of all 0's, Do a ipconfig /renew at the command prompt. That should give you an ip from dhcp. If it hangs there after running the command, check to see the driver for your nic is installed.


This is a link to the user guide for your router. Run through the steps in chapter 5 and verify the basic settings are correct.
users guide

0

1. Yes, that's the right router and I get 192.168.1.x for a 'normal' IP

2. Let's just deal with CompA as both could get confusing. I don't really need to fool with CompB at the moment as it works - unless you think I need to address that to fix the problem.

3. OK, I can't ping anything on CompA as it doesn't have a connection at all to the router. When I plug directly into the modem, I get zeros. I put ipconfig /release and got

All adapters bound to DHCP do not have DHCP addresses. The addresses were automatically configured and can not be released.

on typing ipconfig /renew I got

The following error occurred when renewing adapter Local Area Connection: DHCP Server unreachable.

Explanation you need to be aware of:
This computer came from Spain (I just moved back home) In my original explanation of the problem I mentioned that I changed the hard drive. That came from a Spanish computer, also. I just upgraded the Spanish O/S to the English version of Win2K from Win98. I am using the nic from that second computer which was supplied from the Telephone company who provided me with ADSL services. I remember that they had to address this card to make it work. I'm wondering is they hard coded something into the card. fyi, this service used a router that attached directly to the telepone line with DSL coming through.

Further, this nic is a Realtek chip set and I have two other that are not from the telephone company. I'm going to go ahead and change this out to make certain because they others are not programmed, I know for sure, they are just generic.

zeroth

0

Just to bring this thread up to date, I found the problem last week. Although I tested the cable in one of the working computers and it gave no problems, I finally replaced the cable and the new computer works fine.

I´ve since done some testing on this cable and continuity checks OK. It is a mystery why it won´t work with the new computer but I have trashed the cable so I won´t make the same mistake if I add another computer. Some mysteries are destined to remain mysteries...

0

Is there any reason why you haven't configured IPs manually. Once you've done that you should be able to ping test both the loopback and the gateway / router address and have a better idea on what the problem may be.

If your using web browser to test, have you deleted any old connections / settings to say use dial up. I rebuilt my laptop trying to add to the wireless router / modem I have because I messed the internet explorer settings up so much, (it needed a rebuild anyway). Like you I ocasionally got a connection, but nothing that stuck.

Hope this helps.

0

Hi Marty,

Sorry, went off this thread and just happened to look at it again but thanks for the help. I did find the problem in the cable, very obscure. All seems to be working perfectly at the moment. I appreciate the help.

0

I must have been half asleep reading the last post before mine, missed the fact you found the cable to be the problem. Glad you got it sorted anyway.

0

That´s OK, I´m half asleep about half the time myself.

Yes, the cable was always a suspect but I couldn´t believe it could be that. There´s a post elsewhere about all of this, so won´t repeat here. But in the end, I´ve got a nice little 5-computer, part-wireless net in the house on a 5Mbps cable modem that hums. No problems since and thanks to all of you for the help. btw, it´s a linksys router and setting that up was like falling off a log, never a problem with that.

zeroth

0

hey,

I am using a linksys router. I have 2 PC's on the network 1 of which works (1 im on :D) 1 of which can see the router but wont connect to the internet. i was wondering if any of you could help. The PC that wont connect to the network is new i have just built it i woz wondering if there was any drivers or anything i need to do.

Carl

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.