0

I'm trying to host a Minecraft server on a Openshift DIY gear and my friend wants to join.

I have a SSH key for him, and when I run this in cmd like the documentation says:

"C:\Users\~Jacob\Desktop\putty.exe" -ssh -i "C:\Users\~Jacob\Documents\ssh.ppk" -N -L 127.5.90.1:25565:127.5.90.1:25565 53fd2ff4e0b8cd67260003c5@minecraft-awesomeserver.rhcloud.com

It says in PuTTY that it is authenticating and gets stuck at "authenticating key". I can type and stuff but the commands don't execute. I had to add the extra commands from the original documentation because ssh alone doesn't work and without mentioning the .ppk file it will not attempt to connect, as the server will refuse to connect.

Here is the documentation:

https://blog.openshift.com/free-minecraft-cloud-server-hosting/

The part where you see "add friends" I followed. I guess since the tutorial is outdated the commands broke or something but I know there is a way without rhc tools and git installed because I can access my server via SSH without those, its just when I try tunneling using the command line is the issue. I just don't want other people having full access to my other projects also on the host, and also for them having to download all that stuff is a pian.

Anyone know what to do in my situation?

3
Contributors
2
Replies
15
Views
2 Years
Discussion Span
Last Post by rubberman
0

The settings as you've given there, does just what it's suppose to do, it didn't start a commandline shell given the -N option ;)

But it did authenticate, and the port forwarding is suppose to have been setup (those -L lines), else it should've given a authentication error.
So now you should follow the rest of the instructions to have the minecraft client connect to the server using your locally forwarded ports.

See here for the explanation: http://jamesmcdonald.id.au/faqs/others/putty/PuTTY%20Command%20Line%20Options.txt

3.7.3.12 `-N': suppress starting a shell or command

   The `-N' option prevents PuTTY from attempting to start a shell or
   command on the remote server. You might want to use this option if
   you are only using the SSH connection for port forwarding, and your
   user account on the server does not have the ability to run a shell.

   This feature is only available in SSH protocol version 2 (since the
   version 1 protocol assumes you will always want to run a shell).

   This option is equivalent to the `Don't start a shell or command at
   all' checkbox in the SSH panel of the PuTTY configuration box (see
   section 4.18.3).
0

The remote user's ip address has to be registered in the ~/.ssh/known_hosts database. You might want to review the ssh man pages for better understanding of what is needed for remote connection with ssh keys.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.