Start New Discussion within our Hardware and Software Community

I have a troubling problem. I have a Dell Dimension 4600 that seems to be compromising my wireless network at home. It is running Windows XP with SP3 and it can connect to the network. However, whenever I try to download anything, or click a link, all computers connected to the network are disconnected. (Including the Dell) It is using a Rosewill RNX-G300LX PCI wireless card. I have no clue what the problem is. The card behaves fine in every computer it will fit in other than this specific one. Any suggestions?

Hard to say, but it is possible that traffic coming from this particular PC is locking up your internet router. Check to see if there are any firmware updates that could be applied to the router.

also, verify that you have the latest drivers updated on the network devices.

Unfortunately, I can't change anything about my router. It's provided by my cable company, and they don't even let me mess around with the configuration page. Also, the drivers for the network adapter are up-to-date.

Try a different wireless adapter on the DELL that appears to be causing this issue and monitor the network to see if you reproduce the issue.

I tried a different adapter, and the same thing happened. This adapter has also worked in computers other than this one on this network.

I'm guessing there's not much else I can do besides leave the computer unconnected?

You can easily determine if this is a hardware or OS problem. If you download a Linux bootable CD that supports that adapter, boot from it and see if you can connect. If you can, then you know the problem is with Windows. If that's the case, format the drive and reinstall windows from scratch.

I tried booting Ubuntu 12.04 from disc, and the machine wasn't able to handle it. I'll have to try a version with lower system requirements.

I tried Puppy and I can't even set up a connection. I forgot to mention something that may be important earlier: my SSID isn't broadcasted. It has to be typed in to set up a new connection. When I try this with Puppy, I have no success.

The purpose of booting to another operating system was just to validate that you could get the adapter working on that computer without any issues. You already validated that this adapter as well as others work fine on other computers on the network.

Since you couldnt validate this adapter on that DELL hardware, while the evidence is pointing to the fact that the problem is localized on that DELL we still dont know if its your Windows installation or something else on that box.

I'm not confident that I set up the connection correctly in Puppy. I'm rather inexperienced with Linux, and the tool I used to configure the connection seemed like it only expected networks that broadcast their SSID.

This article has been dead for over six months. Start a new discussion instead.