0

I was going to post this in the linux/unix board, but there is no 'start new thread' button. Why is that? Anyway, I'm going through a ton of steps to apply a patch file. Everything in the patch file seems to apply seamlessly, with one exception. My patch file is a .tar.gz and, when extracted, it contains a file with the path

/usr/src/linux/arch/x86/include/asm/unistd_32.h

Is there some obvious reason why when I apply the patch, every other file is updated to what I'd expect, but this one is not?

1
Contributor
1
Reply
2
Views
7 Years
Discussion Span
Last Post by BestJewSinceJC
0

Well, I still cannot figure out why the patch refuses to take the unistd_32.h file into account, which contains the #defines for my custom system calls. Since my user programs use my system calls, it then causes the compilation process of my .c files to fail. I found a workaround with the help of my TA where instead of "__NR_customSysCall" in my C file, I just put the number of the #define. This allows my code to compile. Unfortunately it still doesn't make sense why the unistd_32.h doesn't get included.

Since I found a workaround, albeit a crappy one, I'll mark this solved.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.