1

Hi

I installed mssql200. It works fine, but outside application can't communicate with it because it doesn't open port 1433 as it is configured to do. Instead it opens 2 other ports that communicate with the DNS server.

What is required to change in order to open port 1433?

Ronni

9
Contributors
10
Replies
16
Views
10 Years
Discussion Span
Last Post by barresoft
0

Are you talking about the Windows Firewall?

If so, you need to add an inbound exception to the firewall on the box that has SQL Server installed on it. Also, make sure that your SQL box is not using dynamic ports.

-- Andy

0

Recently I experienced the same situation. I came across a tutorial at a Java Mag web site that showed port 1864 was the port to use in a connection to a SQL db.

good luck

0

Hi

I installed mssql200. It works fine, but outside application can't communicate with it because it doesn't open port 1433 as it is configured to do. Instead it opens 2 other ports that communicate with the DNS server.

What is required to change in order to open port 1433?

Ronni

Did you manage to fix this ?

We are having the same problem

0

First, goto connectionstrings.com and look at the various connections strings.

Yes, I finally got a jdbc (java) connection string to work, and had to configure the java application as a trusted connection with mssql server.

Using java, you will also need to download the mssql jdbc drivers from microsoft and use them in the java connection string as the driver.

Are you using java or vb# ,c#.

You are attempting to connect to a remote server correct

cplmckenzie

0

We are trying to connect via VB
port 1433 is configured to be open but when we run netstat -an it is not showing as an open port

0

Hi

I installed mssql200. It works fine, but outside application can't communicate with it because it doesn't open port 1433 as it is configured to do. Instead it opens 2 other ports that communicate with the DNS server.

What is required to change in order to open port 1433?
Pls help me

lalit

0

For SQLServer 2005, try this: http://support.microsoft.com/kb/914277

For SQLServer 2008, I found settings in the "Sql Server Configuration Manager" tool. Look under the "SQL Server Network Configuration" branch for "Protocols for <SQLEXPRESS>" and change your install to not use dynamic ports (clear out the default "0" entries and add 1433 to the static port fields).

0

I opened SQL Configuration Manager via Start > All Programs > Windows Server 2008 > Configuration Tools > SQL Configuration Manager. Expand SQL Server Netowrk Configuration > Protocols for MSSQLSERVER. Right click on TCP/IP click on properties. Click on the IP Address tab on Enabled select yes.

Run services.msc. Restart SQL Server (MSSQLSERVER).

Then continue install.

This worked for me.

0

In SQL SERVER CONFIGURATION MANAGER -> go to Network Administration Protocols and look on IP ADRESSES!!!
Then, enable the interface, and on the bottom, type "1433" on port, and delete "XXXXX" dynamic port if presetted!

This is the solution.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.