0

Hello,
Recently I needed to assign keyboard control to my program; so and I searched the Internet, I found many examples but it seems all have one little problem(or it's my mistake?):
I use this test code:

using System;
using System.Collections.Generic;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Linq;
using System.Text;
using System.Windows.Forms;

namespace myheys
{
    public partial class Form1 : Form
    {
        public Form1()
        {
            InitializeComponent();

        }



        private void Form1_Load(object sender, EventArgs e)
        {
            this.KeyUp += new KeyEventHandler(button1_KeyDown);
        }



        private void button1_KeyDown(object sender, KeyEventArgs e)
        {
            switch ((int)e.KeyValue)
            {
                case (int)Keys.Space: MessageBox.Show("SPACE"); break;
                case (int)Keys.Escape: MessageBox.Show("ESC"); break;
                case (int)Keys.Enter: MessageBox.Show("ENTER"); break;
                case (int)Keys.Delete: MessageBox.Show("del"); break;

                case (int)Keys.Up: MessageBox.Show("up"); break;
                case (int)Keys.Down: MessageBox.Show("down"); break;

                case (int)Keys.Left: MessageBox.Show("left"); break;
                case (int)Keys.Right: MessageBox.Show("right"); break;

                case (int)Keys.F10: MessageBox.Show("F10"); break;

                case (int)Keys.F: MessageBox.Show("f"); break;

            }
        }
    }
}

Keyboard control works fine but not for all key: Enter, Up, Down, Right, Left -> these are not working.:( . I don't understand why, because these controls are defined in c# like the others. If you have an idea, please post it. Thanks :)

2
Contributors
5
Replies
6
Views
8 Years
Discussion Span
Last Post by LizR
0

What control currently has focus? Sometimes a control with focus can prevent some of these things working

0

Thanks for reply. It has assigned 'button1_KeyDown' to the keydown property. 'button1' is focused. other keys work but those keys dont work.

0

The button is eating your keys, if you remove the button the problem goes too If all you're using is the button to get the events setup, dont, use the forms direct.

0

:) . LizR, you're right. The button ate my keys to access itself. THANKS! You solved my little annoying problem :) !

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.