0

Hello all, I created a crystal report which works perfect local but in production work partial, it means that there are 3 specific values that the report does no retrieve, is there any particular reason why this happen?.

thanks.

2
Contributors
4
Replies
5
Views
7 Years
Discussion Span
Last Post by jbisono
1

Hi. Did you figure this problem out yet? I could simply give you a short and precise answer to your question--Yes (LOL), but you probably want to know what the reason is too, right?

Can you attach the report file and list what the "3 specific values" are?

0

The fields are DefectType, RootType in the Page Header C section and also the details section complete thanks

[ATTACH]11524[/ATTACH]

When I opened this report, I got some sort of wizard or installer telling me it was created in a new version of Crystal. Anyway, I'm not very familiar with this Crystal built into the VS IDE and it's been years since I've viewed a report in the Crystal Designer, which was a separate product then, but I noticed something when using the Select Expert on the DefectType field. The selection formula reads:

{tbl_Main_NCR.NCR_NUMBER} = {?NcrNumber}

but, shouldn't it somehow show a tie to the DEFECT_CODE for that record? I don't know proper formula syntax, but I hope I will convey what I mean in this snippet:

{tbl_Main_NCR.NCR_NUMBER} = {?NcrNumber} && {tbl_Main_NCR.DEFECT_CODE} = {EW_DEFECT_CODE.DefectCode}

Sorry if I'm way off base here. I tried to find some visual linking expert so I could visual examine the linked tables to verify that there was indeed a link on the DefectCode, but couldn't find that option in my IDE.

0

thanks for you reply actually i fixed it, I just create a command statement with my query and i map my fields with the old ones and its working now, i guess the fact that i was working with two different datasource was the problem thanks anyway.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.