when i run cat . i displays some weird characters which is fine, but after that i can not turn back to my normal directory path. it always shows some weird characters in my directory path too.

Why? how to turn back?

Use reset to reset your shell. You can use cat /dev/urandom to get random junk data which should screw your terminal up, then issuing a reset should fix it.

No -- This will not reboot your computer :)

What is your prompt? Post the output of set . It fixes mine.

Can you take a screenshot of the before and after of your terminal being screwed up?

Edited 7 Years Ago by sknake: n/a

if i post the output of set, the bosses would put me out :D
about the screenshot, it is not possible because when i run your command, it goes in an infinite loop and keeps showing some characters continuesly.

^Z sends a process in to the background (detaches, not truly the background):

Use "fg" to return to nano.
                           zsh: suspended (signal)  nano
$

So how about those screenshots or +solved? :)

Edited 7 Years Ago by sknake: n/a

Nah, I have fun posting :) The little number doesn't do much for me. What I really like is when people ask questions that I don't know the answer to and it interests me so I go and learn something new. That is really what i'm about. Plus its been fun getting to know you guys. Danny turned me on to a new beer making 2.5k posts worth it!

could you elaborate "Danny turned me on to a new beer making 2.5k posts worth it!"
i didnt get it :)

I was answering one of his posts and later on in an email he was telling me about another Belgian beer he liked, Duvells, because I was talking about Allagash White. I went up to the liquor store and picked up some Duvells and it was worth it :)

Attachments monster.jpg 29.5 KB

Oh Scott, my friend, Danny needs to tell you about Belgian girls, you can get love drunk of their beauty. Once i met a Belgian girl, Emy Dupont, because of her i learned French language..

it is time to make you happy Scott, i mark this thread as solved, the solution to this problem is to close your telnet application and reopen it.
when you try to cat a binary file, it corrupts the command prompt.

This question has already been answered. Start a new discussion instead.