i got a problem with my visual studio 2010
the properties window doesn't display anything whenever i click any control
i've tried reopening the properties window, opening some old solutions and restarting the program, but it still the same
i've also reinstalled visual studio but it didn't help either
my friend said that he never encountered such a thing so doesn't have any idea what went wrong
google doesn't much help either

thanks in advance

Is it happening in web project? I had this problem while working on web project. And coincidentally yesterday I solved it. After clicking on the tags which are shown just below design window properties appears again. I have uploaded the image so you will understand what I am saying exactly.

Attachments Capture.PNG 5.06 KB

Is this happening with all your projects or just one particular project?
Does it happen if you create a new project?

@Sahil89, no i'm using c# and vb. i

@TnTinMN it happens to all my projects..
expecially when i create new projects the properties window is completely blank even when i tried adding and removing controls.. with regards to my old projects, SOME controls have properties displayed and when i tried selecting other controls it doesn't show anything and even when i add new controls the properties window is still blank..

Well the problem being wide spread rules out my thought of a corrupted solution file.

If I remember correctly, last weeks update's from MS patched all versions of .Net (1.1 and up). There could have been something in those that is causing an issue. look in your update log and try uninstalling them.

My only other suggestion is one I dread doing as it is time consuming, but I would try removing VS again and also uninstall the .Net framework and then reinstall everything. The problem is that there is no guarranty that this would solve the problem.

i'm sure that my vs was not updated ... and it is not a corrupted solution file that's causing the problem because the solutions work well in my laptop's vs ..

and that's what i have in mind if i can't figure out what the problem is ..
but as you said it's time consuming..

anyway thanks..
i'm still hoping that i can figure it out so that if the problem occurs again i can fix it and not have to undergo reinstalling EVERTHING

This article has been dead for over six months. Start a new discussion instead.