0

Hi friends.

I am trying to install Ruby on rails on Linux platform.The OS i am using is Ubuntu.
I am new to both Linux and RoR .So really need help.Here is the code i tried to run and the result :

manisha@manisha-desktop:~$ sudo gem install rails --include-dependencies

/usr/bin/gem:11:Warning: Gem::manage_gems is deprecated and will be removed on or after March 2009.
INFO: `gem install -y` is now default and will be removed
INFO: use --ignore-dependencies to install only the gems you list
ERROR: http://gems.rubyforge.org/ does not appear to be a repository
ERROR: could not find gem rails locally or in a repository

I tried many probable solutions , but none is working.I am just unable to figure out any more.May be someone can help.I will be very thankful.

3
Contributors
5
Replies
7
Views
9 Years
Discussion Span
Last Post by MrAntonio
0

yes i have the firewall and i aslo set the required proxy for that.it was working on windows but dont know why it isnt working for linux.

0

Try specifying the proxy in the gem command with sudo gem install rails -p [proxy url]:[port] . If that doesn't work, try setting the environment variable with set HTTP_PROXY=[proxy url]:[port]

0

I have already set the proxy.But still it wasnt working. Now when i used the proxy thing along the command,
I can just do
$ sudo gem update

Even I am having error to do

$ sudo gem update --system

I dont understand why this is happening :(

0

Hi guys,
There was such problem as at manisha, thanks a lot destin your recommendations have helped! :-)

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.