Hello Folks,

I have an ASP.Net 2.0 web application which was successfully debugged, published, uploaded and tested on IIS server. But the problem is, I can access this application on my localhost only but when I am trying to access this from some other machine which is also in the same network as my localhost in, it just simple not finding the application.

My machine's name is NODE5. And the name of the other machine is NODE15. I just typed http://localhost/<my virtual dir>/ on my localhost and the application pops up successfully. Then I tried on other machine by typing http://NODE5/<my virtual dir>/. But after hitting enter the following message is displayed on browser :-

Internet Explorer cannot open this webpage.....

Could somebody tell me what is actually causing the problem.....Plzz guys its very urgent....any soon help/rplys will be appreciated...

Thanks for any help.....in advance

regards
Shouvik

thanks for your reply.....but I have already tried both techniques in my local host....both worked.....but the same seems to be worked on remote machines also....but it is not working as expected......

running the application on my own server is not the problem for me as well as not the topic to be discussed on this thread...my question was how to run the application from another machine which also resides in the same network as my localhost do....so if you have any solution to this then post.....

thanks...
regards
Shouvik

Hello Folks, Thanks for viewing this thread....

Finally I have solved the problem....now my application is running from any node connected to my office network...

This thread is now closed..

regards
Shouvik

Hello Folks, Thanks for viewing this thread....

Finally I have solved the problem....now my application is running from any node connected to my office network...

This thread is now closed..

regards
Shouvik

I am also stuck in same problem. Could you please post the solution here

This is weird that when someone needs a solution they start creating threads everywhere in the world but when they find the solution, they are not courteous enough to share the solution also in the threads they created themselves......

Stuck in same problem....If anyone else has a solution please share..

Edited 3 Years Ago by Kamal_4

Thanks for reminding me about this after 4 years...
The solution was simple but I had spent many sleepfull nights in finding that.. :)
Here is what I had done in solving this issue :-

The problem was, NODE5 was not recognized as a web-server in our intranet network. So what I did, just set my localhost as a webserver from LAN settings. Below are the steps :-

  1. Open Control Panel
  2. Goto Network Connections
  3. Here you will find your LAN connection name under "LAN or High-Speed Internet" section. In my pc, it was "Local Area Connection 4".
  4. Right click on it and goto Properties.
  5. Click on Advance Tab and then click Settings. The Windows Firewall dialog will popup. Though you can directly open it from control panel but still I am writing the exact steps I performed 4 years ago.
  6. In firewall dialog, goto Advanced tab.
  7. In the list of connections, under Network Connection Settings, select your LAN connection name (in my case, "Local Area Connection 4") and click Settings.
  8. The Advanced Settings dialog will open. Goto Services tab.
  9. In the list of services, you will find "Web Server (HTTP)". Also make sure that Port No. 80 is open and granted access in windows firewall (if its enabled).
  10. Check it and when the service settings dialog will open, mention the name of virtual web-server in your intranet network. It will take your machine name in default. You can keep it or you can also change name.
  11. Continue hitting OK untill you close all dialog.
  12. Restart your pc and on next login you can access your application via your intranet network using the same name you defined as web-server.
    e.g. http://<web server name>/<your application virtual directory name>/<name of start page.aspx (if any)

Hope this will address your issue.
Thanks
Shouvik

Comments
Shared after four years, wow!
This question has already been answered. Start a new discussion instead.