0

im new to sql but long story short.

just installed mysql server 5.5 and started the configuration and it failed to apply the security settings with error message 2003, cant connect to server on local host. so i cant finnish the installation and canot run mysql.exe. it just beeps at me.

WHAT I HAVE TRIED:
i have turnd of firewalls, virus proggys and anything else i could think of with no joy

i have looked at other posts regarding this error but they all appere to be problems regarding code on already installed coppies of mysql.

i checked to see if the service is running. which it does appere to be.

i have noticed that i have numerous copies of microsoft sql server. 2005. 2008 and various subsidiary progs installed. could they be interfearing. i dont know what installed them or weather i should remove them or not.

can any one help me get this installed?

4
Contributors
7
Replies
9
Views
6 Years
Discussion Span
Last Post by Wattsits
0

How are you running mysql? Apache, IIS? Are you running a WAMP/XAMPP package?

Firewalls are the obvious culprit. Port 3306 is the usually the default for mysql - so this should be made available.

Edited by diafol: n/a

0

Try this attachment. It will tell you what port is being used and whats not. Next time, please post this in the correct forum. This has nothing to do with PHP, this is more of a software thing. On another note, google XAMPP. This is a really great bundle that comes with alot of different scripting languages.

0

Hi guys.
Sorry for posting in the wrong room, ill try n be more carefull.
no WAMP/XAMPP. all iv done is try and install mysql 5.5. it did install but failed on the configuration setup.
the first few times i tried this i couldnt run mysql.exe but even tho the config faild last time, i can run it now. i can log in to the root from the cmd prompt. so i think its working now.
i am new to this so i dont know many commands in the shell
its installed on windows atm
iv got port 3306 open on my router/firewall
i will have a look at that xampp in a bit, thanks.
i was wondering how to get out of '> prompt. i tried INSERT INTO a tables field and it left with a prompt '> and not -> . i guess im missing some fundamental controle of the shell.
anyway, thanks for the quick response guys.
steve.

0
mysql> quit

You also have to finish statements from the command prompt with semi-colons.

show databases;

If you can access it via the command line and everything is working, from your localhost you should NOT have a firewall/port issue as the request never leaves the local machine.

0

i typed
mysql> insert into test_increment(test_name)
-> values ('fred'),('joe'),('mike'),('ted');
and instead of doing it the next prompt was
'> and not ->
i did end with a ;
i tried select * from test_increment; and show databases;
but all im getting is '> :(

0

ok dont worry. iv answered this my self now.
@ '> prompt i did
'> ' return
->
done :)
i noticed i missed a ' out of the values line
i will mark this thred as complete now
cheers guys.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.