0

hello.
i have oracle 11g installed on 64 bits laptop running with windows 7.
and i manage the ODBC driver fro oracle from the administrative tools ,and i tested the connection from there and everything is okay.
but then i tried to connect to oracle 11g DB using visual studio 2010,so i have this error:
"ERROR [IM002] [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified"
so the problem that i have an 64 bits driver and visual studio 2010 is a 32 bits, so that is the problem.
so anyone had an idea to solve this problem?
thank you in advance.

2
Contributors
4
Replies
6
Views
6 Years
Discussion Span
Last Post by cocoll
0

Did you check your webconfig file for data source like orcl etc , and also listener , some thng you missing or not configured properly.
1st check listeners and ping at that maching
2nd check web.config
3rd connection string in your application.

Best of Luck

0

thank you for your reply,but i am so sorry,the error is:

ERROR [IM014] [Microsoft][ODBC Driver Manager] The specified DSN contains an architecture mismatch between the Driver and Application

so if i can use another method for connection or another driver,so i really appreciate the help.
thank you.

0

why i need web.comfig,i don;t use it,i know that i can put the connection string in it and others but i don't use it at this stage,i tried to connect to oracle 11g with windows application with no succeed,however i will put the code and the web.config.

using System;
using System.Collections.Generic;
using System.Linq;
using System.Web;
using System.Web.UI;
using System.Web.UI.WebControls;
using System.Data.Odbc;
public partial class _Default : System.Web.UI.Page
{
    protected void Page_Load(object sender, EventArgs e)
    {
        String con = "DSN=orcl;Driver={Microsoft ODBC for Oracle};UID=system;PWD=password;SERVER=localhost;";
        OdbcConnection conx = new OdbcConnection(con);
        conx.Open();
        conx.Close();
       
    }
}

the web.config that i don't use:

<?xml version="1.0"?>
<!--
  For more information on how to configure your ASP.NET application, please visit
  http://go.microsoft.com/fwlink/?LinkId=169433
  -->
<configuration>
	<system.web>
		<compilation debug="true" targetFramework="4.0"/>
	</system.web>
</configuration>

i searched in the internet and the problem that oracle 11g driver is 64 bits and VS 2010 is 32bits.
thank you

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.