syd919 0 Junior Poster in Training

Hello people,I hope everyone is well. I am having problems with my connection string.
It seems its not detected at all. I am designing a Silverligtht app with a Linq to SQL connection for the data.
Here is my code.

ConnectionStringSettings settings = ConfigurationManager.ConnectionStrings["DataConnect"];
        string connection = settings.ConnectionString;

        DataContext dataContext = new DataContext(connection);

and code in web.config file:

<configuration>
    <configSections>
    </configSections>
    <connectionStrings>
        <add name="NucleusConnectionString" connectionString="Data Source=ServerName;Initial Catalog=Nucleus;Integrated Security=True"
            providerName="System.Data.SqlClient" />
        <add name="TravelPlannerProject.Web.Properties.Settings.DataConnect"
            connectionString="Data Source=ServerName;Initial Catalog=Nucleus;Integrated Security=True"
            providerName="System.Data.SqlClient" />
    </connectionStrings>
    <system.web>
        <compilation debug="true" targetFramework="4.0" />
    </system.web>

    <system.serviceModel>
        <behaviors>
            <serviceBehaviors>
                <behavior name="">
                    <serviceMetadata httpGetEnabled="true" />
                    <serviceDebug includeExceptionDetailInFaults="false" />
                </behavior>
            </serviceBehaviors>
        </behaviors>
        <serviceHostingEnvironment multipleSiteBindingsEnabled="true" />
    </system.serviceModel>
</configuration>
Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.21 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.