Hello.

I don't know what I did or what has happened, but all of a sudden when I try to click my RSS feed link on my Wordpress blog, I get this error:

XML Parsing Error: xml declaration not at start of external entity
Location: [url]http://www.justwantaquote.com/blog/feed/[/url]
Line Number 2, Column 1:<?xml version="1.0" encoding="UTF-8"?>
^

Anyone have any idea about how to fix this problem? I have no idea what I did really, except I added some plugins. I have disabled most of them now, but I still get this error.

Any ideas on how to fix this will be greatly appreciated.

Thanks.

I know the error, but not specifically how to fix for wordpress.

The error is because XML parsers expect the <?xml> tag to be the very first thing in the file. Your file is either blank, or has a blank line inserted before that tag. If it is something you generate, you may want to open it in a text editor and take a look.

Hello.

I don't know what I did or what has happened, but all of a sudden when I try to click my RSS feed link on my Wordpress blog, I get this error:

XML Parsing Error: xml declaration not at start of external entity
Location: [url]http://www.justwantaquote.com/blog/feed/[/url]
Line Number 2, Column 1:<?xml version="1.0" encoding="UTF-8"?>
^

Anyone have any idea about how to fix this problem? I have no idea what I did really, except I added some plugins. I have disabled most of them now, but I still get this error.

Any ideas on how to fix this will be greatly appreciated.

Thanks.

Any Idea as to which PHP file on the wordpress installation this error is related too? Which file would this problem even be related too? I have no clue lol. And thanks for the tip!

The XML file has an empty first line which is why you are getting the error.

You need to search your Wordpress directory for XML files and if you have Dreamweaver - try using a text search to find the XML file itself - try looking in this folder
justwantaquote-finance-blog/feed/

This article has been dead for over six months. Start a new discussion instead.