0

Hey everyone,

I am having trouble accessing the web pages on my online server. On my local server, I access them using this URL(localhost/mvc/users/index) But this doesn't allow me to access the pages except for the config page which is on mysite.com/mvc

Any help please?

2
Contributors
3
Replies
4
Views
5 Years
Discussion Span
Last Post by veedeoo
0

what happened if you access yoursite.com/mvc/users/ ? Does it give you an error message about app/Controller/UsersController.php?

0

Yes, it does give me an error that says " page not found.... The requested URL /mvc/users/index was not found on this server."

0

can you check if rewrite_mod is enabled on your server? Inside your directory yourSite.com/mvc there should be an .htaccess file that came with the phpcake files.. the codes on it look something like this. Actually there are two of them.. one is located in the app/directory.

<IfModule mod_rewrite.c>
 RewriteEngine on
 RewriteRule    ^$ app/webroot/    [L]
 RewriteRule    (.*) app/webroot/$1 [L]
 </IfModule>

If your root directory have a pre-existing .htaccess, try experimenting by adding the same entries you found on the .htaccess in mvc/app/ directory.

Be carefull when uploading and editing .htaccess file. There are times this file can get corrupted, even if you set the FTP program file transfer type to auto.. Some server are pretty delicate on this settings. Sometimes, setting it to binary works.. However, .htaccess file is more of an ASCII file rather than binary, but it works for me all the time using the setting as binary, because I have lots of php files with the extensions such as .inc .module. So, setting it to auto makes the ftp program go flip/flopping between binary and ASCII and this behaviour is enough to corrupt the php files with different file extensions,

Edited by veedeoo: more info added

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.