0

I have a domain registered.

I've uploaded my pages in httpdocs of my webspace. Other html pages are working fine, but my asp.net pages are not working properly. when i try to load those pages i am getting error as below :

Server Error in '/' Application.
--------------------------------------------------------------------------------

Runtime Error 
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine. 

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>


Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>

Kindly advice..

Vivek

3
Contributors
2
Replies
3
Views
4 Years
Discussion Span
Last Post by JorgeM
0

Are you sure you uploaded all files (including the binaries) ? Follow the guidelines in the error, and turn custom error reporting off. If you do, you'll get a decent exception.

Edited by pritaeas

0

Have you attempted to run your pages locally on machine? Visual studio has a built in web server that you can use to test your pages prior to uploading them.

You have some type of error in your server-side code. If you want to get a more detailed output of the error, update your web.config file as described in your posting.

You want to turn off the customErrors as described in lines 12-16 from above.

<customErrors mode="Off" />

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.