0

Hi Guys

i have this error in my asp.net 4.0 application , i am strugling to find out
why it is working perfect on my local iis server, but throws this error on web iis server

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

here i have given my we.config file cose as wel
thanks

<?xml version="1.0"?>

<!--
  For more information on how to configure your ASP.NET application, please visit
  http://go.microsoft.com/fwlink/?LinkId=169433
  -->



<configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
  <connectionStrings configProtectionProvider="DataProtectionConfigurationProvider">
    <EncryptedData>
      <CipherData>
        <CipherValue>AQAAANCMnd8BFdERjHoAwE/Cl+sBAAAA55LPwU/GRUKlrYFOe+inswQAAAACAAAAAAADZgAAwAAAABAAAABT02P0fYq92+xlRgJAK3vMAAAAAASAAACgAAAAEAAAAFRrz810llmi6adAQeYOvoPQAQAAW7T513/upk5ED7GpGvGCkAa8Tu6UbSnSrgCY9cnuwE1WKJqKLQ4U4SMLKYHT8hDMZaS1JRbYLMBwb5s5U4L9yACNMO+1AsHSWGpuuWnKn8KZxYwTWZka1ViK+8VG7lGlMKn0L7SJagVtCIRGdmaYGmxKQDUaHS0nW6eTDIvVlSXEFuzfJEGIBO2+7GHui+7YZZOGN7uns7vCZY5VVZIzRy9aHOTnAVsIJe8QPtQpXUg1QANgXPqZNvgGJWhSscd0H45y5MgI4sny1vtbmXVhf0+KI9LfA/RUNCzZOIvtJOHQtglEUW4pUXIVpTsYfWqSPIap/oWxUPpxYgRBas7m4P/R9nie/VbKpWbFV5hIDT8YrKSl40UpI8kYYrZvT2M5XUVrzRARI646ZCgCUiCpPlNrVBqCTaPzsJplFp+CgyGT+ZvcHPGkl+MsdCkYDAldrVQJhLfr0hiBHLbdGV0+plQVAkM9EtG/NLm/iW6ohYhrol8gsK7UVZp/d9uY9OsngHlB5078P5ZlIg9hw771zU8nh49ix6djQ3gvQ6m3PCFii98KMyPUnthUMtW4Pm9AOt1YJoOY4dFSY1bjo80IIWZkHhOxOLnIX5QMeU/hc+cUAAAAEiPVIW1ZkBeJJysGKvLllymbYRY=</CipherValue>
      </CipherData>
    </EncryptedData>
  </connectionStrings>

  <system.web>

    <customErrors mode="Off"/>

    <compilation debug="true" targetFramework="4.0" />

    <authentication mode="Forms">
      <forms loginUrl="~/Account/Login.aspx" timeout="2880" />
    </authentication>

    <pages theme=""/>
    <sessionState cookieless="AutoDetect" timeout="10"/>


    <membership>
      <providers>
        <clear/>
        <add name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider" connectionStringName="ApplicationServices"
             enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" requiresUniqueEmail="false"
             maxInvalidPasswordAttempts="5" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10"
             applicationName="/" />
      </providers>
    </membership>


    <profile>
      <providers>
        <clear/>
        <add name="AspNetSqlProfileProvider" type="System.Web.Profile.SqlProfileProvider" connectionStringName="ApplicationServices" applicationName="/"/>
      </providers>
    </profile>


    <roleManager enabled="false">
      <providers>
        <clear/>
        <add name="AspNetSqlRoleProvider" type="System.Web.Security.SqlRoleProvider" connectionStringName="ApplicationServices" applicationName="/" />
        <add name="AspNetWindowsTokenRoleProvider" type="System.Web.Security.WindowsTokenRoleProvider" applicationName="/" />
      </providers>
    </roleManager>

  </system.web>

  <system.webServer>
    <modules runAllManagedModulesForAllRequests="true"/>
  </system.webServer>


</configuration>

regards
sumith

2
Contributors
4
Replies
12
Views
3 Years
Discussion Span
Last Post by JorgeM
0

If your web.config file is saved in the root directory and you have customErrors, set to off, you should be seeing the actual error instead of the message above.

It has to be in the root directory

0

Hi JorgeM

Here i am sending 2 screen Shots on My Lcal PC Published folder and FileZila on Web server just see whether you can see any problem there ?

Attachments Custom_Error.jpg 116.02 KB
0

You are going to have to contact the provider to figure out what's going on, or if they are overriding your web.config file settings. Again, if you have customErrors, set to off, you should be seeing the actual error instead of the message above.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.