I have a site that I can't seem to figure out. I'm extremely new to asp.net/vb etc...I do C# forms but nothing with web dev. Anyway, my problem is my page declaration shows up on a live website and none of the controls show up(buttons, etc). It works great in the development environment though. I've tried searching directly for this problem, but I don't think I'm searching for the right thing so I apologize if this is a very common question you get. So basically I get <%@ Page Language="VB" AutoEventWireup="false" CodeFile="Default.aspx.vb" Inherits="_Default" %> showing at the top of my page and none of the controls load or work. Any help would be greatly appreciated. Also, I tried putting it in Visual Studio and republishing it a couple times if that helps.

Are you saying that you can see
<%@ Page Language="VB" AutoEventWireup="false" CodeFile="Default.aspx.vb" Inherits="_Default" %>
in the browser window after you have loaded the page?
If yes, your code isn't being compiled or read by the .Net framework. What server set up is it running on?

That is correct, it is showing at the top of the visible page after being loaded. Currently there is a Windows server. It was a Linux server set up, but GoDaddy suggested I try moving it over to the Windows one.

I had the same problem on both server types.

Oh, and the server is setup to run IIS 7 and I just modified the ASP.Net Runtime Version to 2.0-3.5 to see if that helps any. It was showing it was only in the content root directory.

Yeah, you are going to run asp.net pages on a windows server running IIS.

It was showing it was only in the content root directory.

What do you mean, please clarify..

Click Here
Here's a screen shot of "only in the content root directory"
It's pending setup since I changed the asp.net runtime. It didn't work before I did that either to be clear, I just thought that maybe the runtime was too low of a version.

That's the page used to create virtual directories. When godaddy set it up for you, it wasn't necessary for you to go in there and configure anything. I'd configure it back to 4/4.5 whatever the later version is.

Set up your FTP account and upload your docs to the root.

If you are still having an issue, they have decent support. No reason why you wouldn't want to open a support ticket. They will resolve this ASAP. Even if the problem is on your end such as with a bad web.config or something, they will tell you exactly what the problem is. I've opened several tickets with them for several sites/accounts and they have always been able to resolve the problem.

Yeah, it was on a lower version before I messed with it. Oddly enough my account doesn't support 4.0-4.5. I'll talk to them some more about it. Thanks for the help Jorge. You're right about their support to, for the most part they're pretty good(as far as I've seen).

Ok...check back in when you hear back from them.