0

Hi Guys,
I've got a xampp since day one, as i used this for local development, strangely happen yesterday when i started it, i cant view my localhost even the phpmyadmin though the xampp is up and running and the most annoying part is when i open my browsers (GC, FF, Opera) i can only open the google, the rest even those url in my history, when i click it, it doesnt load anymore and display ERR_CONNECTION_RESET though my internet is alive, this happen everytime i start xampp. i cant go on anymore with netsh command blah blah as it requires computer reset every now and then. Can someone or anyone help me with this?

BTW, i also uninstall xampp and replace it with wampp, nothings change.

Thanks and God bless,

OTEP

3
Contributors
12
Replies
36
Views
1 Year
Discussion Span
Last Post by OtepTheThird
Featured Replies
  • Hi Guys, I almost quit on this. i've just finally made it. just wanna share some steps how i did it, here it is: 1. Conducted a system restore. dont worry if you see "restore unsuccessful" after system restore just proceed. 2. I remove/uninstall my installed xampp. base on my … Read More

0

Have you checked Apache log files? If you use xampp they should be in C:\xampp\apache\logs.

0

@broj1 here as some the output of C:\wampp\apache\logs.`

C:/wamp/bin/apache/apache2.4.9'
[Wed Nov 04 15:13:28.768630 2015] [mpm_winnt:notice] [pid 8556:tid 380] AH00418: Parent: Created child process 7588
[Wed Nov 04 15:13:29.899694 2015] [mpm_winnt:notice] [pid 7588:tid 296] AH00354: Child: Starting 64 worker threads.
[Wed Nov 04 15:17:25.547173 2015] [mpm_winnt:notice] [pid 8556:tid 380] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Wed Nov 04 15:17:27.547287 2015] [mpm_winnt:notice] [pid 7588:tid 296] AH00364: Child: All worker threads have exited.
[Wed Nov 04 15:17:55.547888 2015] [mpm_winnt:notice] [pid 8556:tid 380] AH00431: Parent: Forcing termination of child process 7588
[Wed Nov 04 15:39:42.952486 2015] [mpm_winnt:notice] [pid 8100:tid 380] AH00455: Apache/2.4.9 (Win32) PHP/5.5.12 configured -- resuming normal operations
[Wed Nov 04 15:39:42.985488 2015] [mpm_winnt:notice] [pid 8100:tid 380] AH00456: Apache Lounge VC11 Server built: Mar 16 2014 12:13:13
[Wed Nov 04 15:39:42.985488 2015] [core:notice] [pid 8100:tid 380] AH00094: Command line: 'c:\\wamp\\bin\\apache\\apache2.4.9\\bin\\httpd.exe -d C:/wamp/bin/apache/apache2.4.9'
[Wed Nov 04 15:39:42.989488 2015] [mpm_winnt:notice] [pid 8100:tid 380] AH00418: Parent: Created child process 6416
[Wed Nov 04 15:39:43.516518 2015] [mpm_winnt:notice] [pid 6416:tid 296] AH00354: Child: Starting 64 worker threads.

As i have mentioned, i already uninstall my xampp assuming that it would be solution.
Thanks.

0

The log does not show any errors only few notices. How do you access your local server (waht is the local URL)? Do you have entries in the hosts file for your virtual hosts?

0

i have reinstall my xampp and i have this on my log.

[ssl:warn] [pid 2268:tid 268] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name

right now i didnt touch any of my conf in apache, on my host i have my entry of 127.0.0.1 localhost. i use to access my localhost by url, say: https://localhost/example/index.html.

0

Does your server certificate CN (common name) and the ServerName directive in the virtual host configuration match? But I don't think this would prevent you to at least load the homepage. Can you also try with http instead of https?

Also, do you have Skype running at ht e same time? It is known that Skype takes over port 80 and I believe port 443 also. In that case you change ports either in Skype (recommended, if you ask me) or in Apache virtual host config.

0

Yes, before i configure my xampp (httpd and ssl), i have already set my skype to not use port 80 and 443 coz i know it is a reserve port. now on my services and process it is clearly up and running both httpd and mysqld. looking back i dont have any issue on this, dont have any problem accessing localhost/phpmyadmin thru url, and some of my work have database on backend. really have no clue on this problem..(face palm).. I already disable IIS to giveway on port 80, done with netsh winsock reset.

0

Even before we can costumized our vhost, we can already access localhost by accessing index.php or info.php(correct me) when php version displayed or the xampp dashboard, were good to go right?

0

As I remember immediately after installation you should be able to access http://localhost and get the default XAMPP page (or WAMP if you use it), but not https://localhost. Regarding to info.php I don't think it exists by default (but I might be wrong). You have to create it and put phpinfo() function in it, as far as I know.

I also searched for some info on ERR_CONNECTION_RESET. What I found was a bunch of different articles most of them relating to some network configuration issues, like this one: https://www.youtube.com/watch?v=9orMZyky-UI. I do not know how this might help you.

0

Im done with winsock, it fixed my browser but not my xampp problem, hope to figure this out and fix this today.

1

Hi Guys,
I almost quit on this. i've just finally made it. just wanna share some steps how i did it, here it is:
1. Conducted a system restore. dont worry if you see "restore unsuccessful" after system restore just proceed.
2. I remove/uninstall my installed xampp. base on my experience, uninstall.dat file missing so i was forced to manually delete my xampp folder on C:.
3. before xampp resintallation, I check first the skype connection settings, uncheck "use port 80 and 443" this may cause for apache to not start.

This may or may not work on your part. this is the only solution i have.

Thanks,
OT3

0

Well... someone might stumble upon this some day... I too had this err few weeks back... I did all the stuff suggested on different forums... Finally uninstalled and reinstalled...

The solution is actually very simple. I suggest you to uninstall XAMPP completeley (since you might have done some changes here and there)... make sure you move the content of htdocs folder somewhere else.

Reinstall xampp create its shortcut in desktop... Right click on the shortcut and click "Run As Administrator"

That's all... It should work... At least it did in my case... Cheers...

Edited by Albert Pinto

0

Well i did your paragraph 2 before i came up with my solution, but nothings happen. and let me add this, AVG is one of the culprit (i guess, well on my part). coz before this mess, xampp work well with AVG w/o disabling it. wish also this help someone one day..thanks @albert

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.