0

I am using asp and ms access in iis, server. my problem is when i am testing it in my pc it working fine but when i upload the page in server it is not working.
[asp]
<%
Dim adoCon
Dim rsAddComments
Dim strSQL
adoCon = Server.CreateObject("ADODB.Connection")adoCon.Open "DRIVER={Microsoft Access Driver (*.mdb)}; DBQ=" & Server.MapPath("guestbook.mdb")

Set rsAddComments = Server.CreateObject("ADODB.Recordset")
strSQL = "SELECT tblComments.Name, tblComments.Comments FROM tblComments;"
rsAddComments.CursorType = 2
rsAddComments.LockType = 3
rsAddComments.Open strSQL, adoCon
rsAddComments.AddNew
rsAddComments.Fields("Name") = Request.Form("name")
rsAddComments.Fields("Comments") = Request.Form("comments")
rsAddComments.Update
rsAddComments.Close
Set rsAddComments = Nothing
Set adoCon = Nothing
Response.Redirect "guestbook.asp"
%>
[/asp]

can any1 help me where is the error in this code?:sad:

2
Contributors
4
Replies
5
Views
11 Years
Discussion Span
Last Post by code_guru
0

What error are you getting? That will narrow down the range of possible answers we need to give you.

0

What error are you getting? That will narrow down the range of possible answers we need to give you.

its not showing any error msg. just showing a msg that
"There is a problem with the page you are tring to reach, cannot display the page":rolleyes:

0

You need to change the settings in your browser so that the entry for 'Show Friendly HTTP Error Messages' is unchecked.

In IE navigate to:
Tools > Internet Options > Advanced : scroll down to the Browsing section and uncheck the checkbox for 'Show friendly HTTP error messages'.

Apply that, reload the page and you should get a much more meaningfull error message.

0

You need to change the settings in your browser so that the entry for 'Show Friendly HTTP Error Messages' is unchecked.

In IE navigate to:
Tools > Internet Options > Advanced : scroll down to the Browsing section and uncheck the checkbox for 'Show friendly HTTP error messages'.

Apply that, reload the page and you should get a much more meaningfull error message.

thanks buddy the problem is solved.:lol:

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.