hi
I have windows vista home basic runing on my pc , i've installed apache 2.2 and php 5.2.4 ,
i've added all the needed lines to httpd.config and restarted the apache , it's all fine and am not facing any error . but when I test it with the index.php which i have made >>>
<html>
<head>
<title> my first php</title>
<body>
<p> my first php: <? echo "hello world!"; ?>
</body>
</html>
i dont find it working !
in browser i just can see my first php but not the "hello world!"
any suggestion ???

I have had that too, but with php 4.

I solved it by using the tags <?php ... /?> instead of the <? ... /?> Try that and see - it might be a setting somewhere in your config file. Maybe one of the php boffins here will be able to help.

I have had that too, but with php 4.

I solved it by using the tags <?php ... /?> instead of the <? ... /?> Try that and see - it might be a setting somewhere in your config file. Maybe one of the php boffins here will be able to help.

hi Rory
thanks for the reply , i've tried this also ,yet it's not working !

in the config file i've added the following lines :
LoadModule php5_module c:/php/php5apache2_2.dll
AddType application/x-httpd-php .php .phtml
ScriptAlias /php/ "c:/php"
Action application/x-httpd-php "/php/php.exe"

I have copied and registered phpactivescript.dll too.
I realy have no idea why isn't it working fine!!!!!!!!!

uninstall everyting. restart your pc.
install:
1- mysql
2- apache
3- php. (stop apache server before u install)

restart your pc again... then it will work... it happens something depends on what service packets you have installed on your windows..

This article has been dead for over six months. Start a new discussion instead.