This week I have been seeing 'Oops, you don't have permission to post here' appearing a lot after I click submit - usually when replying to a post. I compose my reply, press submit, get the Oops message, hit back, my reply has gone and if I were a newbie I would probably be gone with it rather than starting again. OK, so I compose long messages in my own text editor and paste here, but the shorter ones I don't. When I reload the page and try again, it is always OK.

Only been happening this week, last couple of days in fact.

And, while editing the March newsletter, after the first 'update and send test email' button which worked OK and delivered that edit, I am now getting 'Sorry, but there is no valid Newsletter with ID 0.' and cannot save and send the test email. And it loses everything after the first edit. I will persevere, and keep the final edit here on file if this doesn't fix itself today.

I haven't really changed anything I can think of that might be triggering this, and I haven't reproduced it myself. Does it only happen when in staff sections have you noticed? Are you perhaps being logged out? Could it be a cookie issues?

Happens everywhere, using Chrome on W10 FWIW. Not being logged out, unless I'm invisibly being logged back in when I refresh the page. There is no step between compose reply (while logged in) - get oops message so reload page - reply sends OK (while logged in). Cookies, possibly but nothing has changed at my end either so can't imagine why I'd be seeing these all of a sudden. Will continue to investigate here.

Is anyone else seeing this?!

Also, what is the specific error message because I cannot find the saying "You don't have permission to post here" when I do a phrase search through my code.

That was the specific error: a big Oops followed by the line 'you don't have permission to post here' - I cut and pasted it from the screen in the root post of this thread. Haven't seen it at all today as of yet, and I've replied to a couple of things so far.

It was a real PITA yesterday. Only happening on DaniWeb, browser client no problem with anything else. Cleared the cache, restarted client etc etc. Only thing I didn't do was logout and back into DW again.

Anyway, as I say, seems to be working as expected today and not encountered the phantom 403 (I assume it was just a dressed up 403 error) at all so far.

Didn't happen at all yesterday, so I'm guessing that it was something at my end. I'm just trying to figure out what at the moment. I will mark this as solved so as not to clutter your mind :-)

Did the error message have a DaniWeb UI?

Yep. Identical to your other 'oops' error messages in UI style.

And yet we don't have an error message: "You don't have permission to post here".

So strange. I'm refusing to believe you didn't misread the message for now. :-P

Hehe. I know I'm on a lot of meds, but I am not imagining this one :-) As I say, I actually cut and pasted it off the screen so as to save typing time. God knows where it came from, or where it has gone, but as it's fixed itself I would suggest we stop torturing our minds and move on. If it comes back I will screenshot it to death...

I have had this before in the past, not with DaniWeb but with SSL certification for my own site. What I found to be the issue was that, although I cleared all my cache etc, I had left the Google Chrome taskbar function and "let Google Chrome run in the background" in operation and forgot to close that so I wasn't closing Google completely. Once I closed that and THEN cleared the cache it stareted to work.

If it happens again, try that to see if it fixes it for you.

Member Avatar

I'm refusing to believe you didn't misread the message for now.

That has fried my tiny brain :(

Just to prove I wasn't going mad, got it again today (image attached) with a url for the error of

OK, so I must have thought I had cut and pasted it when I didn't as I got the error wording wrong originally. :-)

Anyway, it's pretty damn close and here it is:


Now that's an error message I can work with.

Member Avatar

Heh heh. So that's the equivalent of being made to sit on the naughty step HG. Whatever have you been doing?

Hmm ... is this reproducable by any chance? What forum threads are you specifically trying to reply to? It's most likely a problem with the specific threads.

That's because Davey linked to a page for admins only.

I've not noticed any pattern to it, to be honest Dani. Seems pretty random. If it does happen again I will start keeping a log to see if any pattern emerges.

There you go, it just happened when I tried to reply here about 30 seconds ago.