0

I am trying to load a software program: One Touch Diabetes Management Software from Lifescan. I am operating on windows XP. This message comes up while trying to load:
did not self register or unregister
C:\WINDOWS\System32\MSRDO 20.DLL
unspecified error
I had talked with One Touch Tech and he tried all he new and couldn't resolve problem. He thought that perhaps it was a Microsoft issue. I couldn't find a place to contact them about this so I am trying here. I am 68 years old and this program is needed to download from my meter to PC. I am somewhat proficient but nowhere near an expert with technical stuff.
Hope someone out there can help

3
Contributors
9
Replies
10
Views
10 Years
Discussion Span
Last Post by CANUCK1
0

Hi

Try to register the dll file in windows.

Press Start > Run and type regsvr32 /s msrdo20.dll then click ok.

Try the program again.

0

Gave that a go but same message came up when trying to load the program.

0

Hi

Thanks for the update.
When you say load, does that mean starting the program after you have installed it, or when you are installing it from a disk?

Sorry for the questions, just need to have an idea of what's happening.

0

Sorry for the lack of information. This happens when I get to the final stage of loading from CD. I have found that the file has something to do the back up in the program. I did what you said and it looked as though it went but I could not find it in system 32. Of course I really didn't know what I was looking for. I did forget to thank you for the quick response.

0

I have been able to start the program after installing it. It seems to have everything with one problem that I know of. I will not locate the USB port that I have the meter connected. It asks for the comport which I have no idea which one it is. I click find or locate port and it comes back saying it can not find it. If we could solve this problem the perhaps I can download from meter which is all I need.

0

When it asks for the com port there should be a couple of USB entries there.

Does the meter come with the software or is is separate and does it come with a driver disk?

0

The software was ordered from the company that makes the meter. It also came with a driver cd which is installed. In the com port area it list 1 thru 9 and then beyond. I tried calling up each of them up to com 9 with no recognition. I also tried the search which is supposed to find the port with no luck.

0

you might need to enable the USB port from in the bios,

PS do you have the latest SP running on the machine.

0

I have sp2 running. If it needs bios work then I will need a great deal of help since I know just enough about them to hurt myself.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.