0

Hello, can anyone help me figure out what is wrong vmplayer. I cannot access the server running as GUEST OS on Fedora8 vmplayer HOST OS. I will look into this some more. I am using it as a web development platform. I can access the internet and even the HOST server from the GUEST, but I cannot access the GUEST server from the HOST! Any help will be very much appreciated. Been googling for hours with no luck. Anyways, thanks in advance.
VMplayer
HOST = Fedora 8
GUEST = Windows XP
GUEST = Windows Server 2003

1
Contributor
2
Replies
4
Views
10 Years
Discussion Span
Last Post by world_weapon
0

Fedora 8 and VMplayer
Steps I had to follow to enable access to the guest server from the host.
Brief summary:
The startup did not work right out of the box for my F8 Installation mainly due to vmnet8 not being up, but I figured it out with a lot help from #vmware channel on freenode and this is how I get it running.
1: Mount the drives.
Because I had the vmdk and vmx files on an ntfs partition, I had to mount those drives so that vmplayer would find them later. This also affected the vmware service from initializing vmnet1. For some reason, without finding the vmx and vmdk files, vmnet1 was never configured. Mounting the drives first so that the files were accessable allowed the service to set up vmnet1 upon starting.
2: Start the vmware services.
I did not want the vmware service to run everytime I booted up so I disabled the service via system-config-services. If you get an error starting the service, you may be prompted to run vmware-config.pl to configure the vmware service and compile the modules. This is in every linux host os based howto, so go and read up like I did if this is where you are starting. Also, EVERY TIME YOU RUN vmware-config.pl IT WILL CONFIGURE THE SERVICE TO LOAD AT BOOT. So before you reset or end the session, and if you don't want the vmware service to run everytime you start the system up, run

system-config-services

and make sure vmware is not selected. Save then quit. To manually start the service using the init.d scripts, just run

/etc/init.d/vmware start

where you can change start to stop or restart.
3: Start vmplayer.
This part is what set up vmnet1 for me. Run

vmplayer

and see what things look like, just run

ifconfig -a

and you should see your eth0 and lo devices as well as vmnet1 at this point. If you also see vmnet8 then you probably don't need to be reading this because this was written because vmnet8 was not setting up on its own!!! Now if your vmnet8 doesn't have an inet, then keep reading, because this is only half the problem.
4: Start the VM machine.
NOTE THAT the last step and this one can be joined by simply double clicking the vmx file. Once inside the GUEST OS, we are trying to do several things. MAKE SURE DHCP IS ENABLED FOR THE PRIMARY NIC!!!! ALSO MAKE SURE THAT THE FIREWALL HAS ALL APPROPRIATE PORTS ENABLED!!! Once inside, go to the command prompt if it is windows, or the terminal if it is another linux or unix OS and run (WIN)"ipconfig /all" or (*NIX)"ifconfig -a". What you are looking for is your primary ethernet interface and the ip to the default gateway and the subnet mask. You will need this for the step later on.
5: Set up the vmnet8 interface.
On the typical install for vmplayer, at least for me on F8, I had to run

/usr/bin/vmnet-netifup -d /var/run/vmnet-netifup-vmnet8.pid /dev/vmnet8 vmnet8

to set up the interface on the HOST OS. Now this just puts it up but does not fully configure it. Just to check things out, run "ifconfig -a" to make sure that you now have vmnet1 and vmnet8. If you get complaints about running the vmnet-netifup command, well, just check make sure the interface is up.
6: Configure the interface.
You are almost done!!! This is the last thing I had to do before I got my system up. Basically you need to tell the HOST OS what to have the network as. This is where the default gateway comes in handy from step 4 . Just run

ifconfig vmnet8 $DEFAULT_GATEWAY netmask $SUBNET_MASK

. Be sure that you change the parts starting with $ with appropriate values. If you are new to bash scripting, $ is the symbol for variables. This is what my command looked like on my system.

ifconfig vmnet8 192.168.2.2 netmask 255.255.255.0

. Go ahead and try to load up the ip of that you got from the GUEST OS in your browser on the HOST OS. If all went well, and you have the ports enabled in the firewall and the server running(IIS or Apache etc. etc.) you should see your pages getting served. Hope this helps anyone out as much as it has me. Have fun with your new virtual machine server development environment. Talk to you later..... ;)

0

I went ahead and disabled the host-only vmnet by selecting no for host-only network in the vmware-config.pl because I was using the NAT system and for some reason the GUEST OS was not able to access the internet. So by choosing no in the config, it does not create the vmnet1 and I follow the steps above to allow the GUEST and HOST to communicate via 192.168.2.* address and still communicate with the internet. Well, it works for me. Hope this helps anyone.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.