0

I switched to Linux then back to Windows, and now I'm trying to go back to Linux again. But somewhere I messed up. Now Linux won't install, saying ext 3 cant be created. Also all my partitions are gone for some reason. Any suggestions?

7
Contributors
18
Replies
19
Views
10 Years
Discussion Span
Last Post by dfmalh
0

So Windows still boots? What are you trying to do, erase your hard drive and everything on it, and just single-boot Linux? Or are you trying to dual-boot between Windows and Linux?

If you have a Linux prompt, post the output of this command:

fdisk -l /dev/hda

If you've got a SCSI or SATA drive, replace 'hda' with 'sda'.

0

Windows doesn't work, for some reason. The partitions are gone and I cant get anything to install. I just want to single boot Ubuntu. Do you think my hard drive died?

0

Get a Linux terminal open. Try writing zeroes all over your disk first:

dd if=/dev/zero of=/dev/hda

Now that your hard disk is erased, try starting up the Ubuntu installer and see if it will let you create an ext3 partition.

0

using a live disk can u mount your hard disk. is it accepting the mount partitions and showing anything atleast??

0

Every time I try to mount the hard disk I get nothing. The message I get is ext3 file system in partition #1 of IDEI master (hda) failed.

0

Did you try erasing your hard drive and recreating the partition table, and finally reformatting the partition(s)?

0

Boot into recovery mode off of a Linux CD.

To erase your hard drive:

dd if=/dev/zero of=/dev/hda

To recreate your partition table:

cfdisk /dev/hda

Then create your partitions, write to disk, and exit.

Then reinstall Linux on the newly-created partitions, and make sure you tell the installer to reformat the partitions one more time. And for good measure, make sure to install your bootloader (usually GRUB or LILO) to the MBR (which is usually the default behavior).

0

I tried the command
dd if=/dev/zero of=/dev/hda

but i got an acess denied after hitting enter.\

Also I couldnt find a recovery mode on the Ubuntu main menu of the live cd.

0

In the Ubuntu boot window, there should be an option that says "configure boot parameters" or something along those lines. Just add single to the end, and hit enter to boot. You should reach the root prompt eventually, in which case you'll have the sufficient privileges to execute the dd command.

0

Is your hard disk detected by bios if so try using fdisk of active kill disk to erase the drive. If you want to recover a partiton to sace data get partion table doctor save the data you need then format the hard drive

0

if u want to install ubuntu
after booting from the cd normally
you shold find some icon on the desktop says "install" it is gonna launch a wizard wich includes a partitioning tool
it is not that hard to use
u could delete the partitions and create the ones u need

0

I was able to get into the recovery mode by adding single to the boot paramaters, and when I did I used both the dd if=/dev/zero of=/dev/hda and fdisk -l /dev/hda commands. I then got a string of numbers in brackets followed by text such as request timed out and unable to reach drive, or something along those lines. Then a critical error message appeared. What does this mean?

0

Hi I an external HD problem.

Here is my situation:

I bought a Seagate Barracuda 500GB SATA 32Mb Cash HD on Friday to use as an external backup HD (thesis, movies, music, etc). The HD is in an Eagle Consus case (support usb2.0 and up to 750GB HDs).

On a XP system, I could partition the Drive but I was unable to format it. Apparently there is some "time-out" error between the USB2 and the SATA connection, I am not exactly sure what it means exactly... but the bottom line is that it can't format the external that way.

I am not familiar with how to partition and format in linux (Ubuntu) so that is why I opted to go for XP... bad choice!

I installed Gparted, and after a long struggle got all the partitions removed, and created new ones. I created 3 partitions, and formated to the FAT32 file system (as a start), checked the 3 drives and they worked, mounted correctly, in Ubuntu and on the XP system.

So I decided to to change the first partition to ext3 file system, and one of the others to NTFS (I downloaded and installed ntfsprogs to do that). Everything fine, and everything is working.

The drives names are however the respective sizes of each partition... that won't do, so I tried to rename them...

I used this for the FAT32 partition: sudo mlabel -i /dev/sdb2 ::usbfat32
and this for the NTFS partition: sudo mlabel -i /dev/sdb3 -s ::usbntfs
and this for the EXT3 partition: sudo e2label /dev/sdb1 usbext3

...bad idea! now none of the drives work.

See the attached picture of the pop up window.

The ext3 and fat32 partitions are mounted, but when you try and access them, it does not work.

When I unmount the drives, I get a message that data is being written to the drive, and I can not unplug the drive. After a while the message disappear, and a new message says that it is now safe to remove drive.

In Gparted I can see the different partitions. See picture.

I included the information windows for the NTFS drive that does not want to mount and also the information window for the ext3 (first partition) which gives me a "superblock" error message.

I can't run a check on any of the drives, it won't work. I can't remove any of the partition, because then the external drive "unmount"...

So, all I want to do is to delete all 3 partitions and start from scratch to create new partition.

Can anybody help with this? Please...

ps. After I changed the FAT32 partition to EXT3 the partition seemed "larger", and the same for the NTFS partition, maybe it is something to do with that...

Attachments Screenshot--dev-sdb_-_GParted.png 37.48 KB Screenshot-gnome-mount.png 28.53 KB Screenshot-Information_about_-dev-sdb1.png 33.5 KB Screenshot-Information_about_-dev-sdb3.png 58.67 KB
0

have you tried letting the live install create the partitions for you? if so do you still get the error?

0

have you tried mounting teh volume again and with Gparted you can re create the disk or are you getting an erro?

0

Hi Malksimon,

Thanks for your reply. I haven't had the time to come back to this post, but I solved the problem. It wasn't really in my hands, the HD was brand new and the first 200+ sectors were bad. Got a new HD (swoped as it was only a day old) and had no problems partitioning and formating with Gparted.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.