0

I'm using wamp on MS-Windows 7, and inside www folder I created cgi-bin folder and put some files in it. When I go to Chrome I enter localhost/cgi-bin and it responds

The requested URL /cgi-bin/ was not found on this server.

There are other folders in www and it can access them ok. There's even cgi-bin.old which it accesses.

Do browsers block people (and me) from gaining access to cgi-bin folders?

3
Contributors
3
Replies
23
Views
4 Years
Discussion Span
Last Post by nayaksuraj57
2

I can't recall exactly where it is, but apache blocks http and https access to the folder named cgi-bin, if you rename it you'll have access instantly.

In your hosts file, apache config or somewhere similar, perhaps your cgi library folder! (I can't quite remember...) actually... Just run a scan for any part of this to find it:

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">

And then change the settings:

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

Then restart the apache service. You should be able to browse into that folder. I had to do this for a project once and found that setting up a simple symbolic link solved the issue.

Also, as a side note, this question was best aimed at the LAMP category ;) Either way I hope it sheds some light onto your situation!

Michael

Edited by mmcdonald

Votes + Comments
Thanks
0

Using this method, my localhost is not not working. And to start it working again, I need to delete the created cgi-bin directory in apache.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.