0

Quick scenario:

Home built computer, P3 1000; Asus CUSL2 MB; 320m Ram.

This machine has worked fine for years until I tried to be all cool and finally upgrade to XP (from 98). Went for a clean install, and never could get to main setup, after first reboot would get hard error:

STOP: C0000221 UNKNOWN HARD ERROR \Systemroot\System32\ntdll.dll


Imagining a possible hardware conflict, I basically removed all non-essential drives, cards, etc. from the machine and tried again - now we are just talking about a MB, a hard drive, cd, floppy.

Still same stop error.

In the interests of making a bad problem worse, I like to play tech with my machine.

So I figured that it was time to flash the BIOS. Yay. Seems to me that with everything else out, could be the MB that was causing hardware conflict.

Went to Asus site, downloaded flash utility and what I am rather confident was right bios file, saved old bios, flashed (apparently successfully), and now the computer won't even post. Powers up, but nothing ever happens

So, at this point I cannot even reload old bios.

Any suggestions before I kill myself, or worse, go to computer repair shop and empty my wallet?

Anymore tricks left in the bag?

Thanks to all who reply, your assistance is appreciated.

wtm

6
Contributors
8
Replies
9
Views
14 Years
Discussion Span
Last Post by silk
0

So the machine worked fine with no hardware conflicts until you decided to screw with your operating system?

Now it won't even post? Check the following ...
A. Was the computer moved around at all (initially) that could result in RAM being misseated, etc.?
B. Is there a floppy in the floppy drive?
C. Try disconnecting the hard drives and see if it POSTs, at least.
D. Any beeps?

Last resort ... www.badflash.com comes recommended.

0

Yes, machine worked fine with no conflicts. Another event led me to the conclusion that I would finally go for the upgrade. Heh, I figured, and you know, how the rest of the drama might have played out.

Computer has been moved around, but I checked the ram etc to see if it is still seated.

Seems to have same result whether or not there is a floppy in the drive (had a 98 boot disk in there with the flash utility to revert to saved bios, but to no avail)

Have disconnected all drives and no posts.

No beeps.

Everything simply powers up and the fans spin.

Only upside is that when I finally put this thing back together I'll have one clean machine!

Thanks for your rapid response, I will check badflash.com and see if I can make the problem worse. LOL.

wtm

0

Thanks for the link, I believe I looked at that earlier in my quest.

I have a licensed OEM copy of Win XP pro that gives this result.

Another backup copy of Win XP pro also gives the same error.

I don't see anything on that link stating that Microsoft will replace the software, however.

But, this still indeed the crucial question, after resolving the bios problem, if this problem still exists then I have gotten nowhere.

Have last ditch attempts available to fix the Bios-

Short the CMOS and see if it posts.

Throw motherboard away - eprom is soldered on lol :)

I will post with any results!

Thanks

wtm

0

Hey wutianming,

Did you solve the problem with the board?

I'm having the same problem a.t.m. :<
Flashed it with version 1009, successfully aflash said, but now
there's the black screen when i switch it on...
bios is soldered on, so removing/replacing is not an option i guess...

HELP! :O

0

Things to try:
1. Start, Run, regsvr32 ntdll.dll
or Start, Run, regsvr32 c:\windows\system\ntdll.dll (there is a space between regsvr32 and c:...)
If no joy then
2. Extract new one from installation disk. Follow the prompts.
If still no joy then
3. Start, Run, regsvr32 samlib.dll (ntdll.dll is dependant upon this dll)
If still no joy then try replacing the ntdll.dll (http://www.dll-files.com/dllindex/dll-files.shtml?ntdll). If this doesn't work, I'd say your hard disk is the major culprit. You might try a new hard disk to see if that's the case.

0

some mbs were not designed to flash easily eg some jetway boards . I flashed one and that one went corupt on me. It may be easier to get an upto date mb to save many headaches, i was gutted when mine went. here's one idea , try a local electronics company with you bios flash on floppy and bios chip abd see if they can program it for free you may have to grovel but it may be worth it, sometime you have to be cheeky, let us know, or do you know any onewith the same mother board you can get the bios to flash by doing a hot swap.

0

hot swapping a bios when it's soldered on will not do psychoman :)

when i put a stick of singlesided 64 mb sdram in the board, along with the doublesided 128 mb windows gave me all kinds of errors when booting windows xp, about missing files etc. when i took the 64 mb out again it worked perfectly again.

another problem i had whas the bad flash. The machine was completely dead after a (according to the flash program) succesfull flash. after a couple of retries on different days, i had still no life, and i was running out of options. then i took all the pci+agp cards and put a pci graphics card in. - THEN, and that probably did the TRICK: i took out the bios battery and booted the system. (with the battery on another table, aside of me for good luck ;) the system worked perfectly WITH the new bios version!

so i replaced the pci graphic card with the agp one, and it kept working just fine. Then i reinserted all the other cards (soundcard, network card, and i even put in the bios battery again) and i had a complete working system again, and a happy girlfriend who could play her music again, and an even more happy me :)

by the way, with the new bios version it still has the errors when booting windows if i put in the 64 mb stick. so that one will never see the inside of the computer again ;)
i think i'm just gonna buy some doublesided memory for this memory hating-bios aggravating board

good luck wutianming! let us know if you have any luck!

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.