0

First, please know that I've already checked out the other threads on the subject and none of the solutions have worked in my case.

Having said that, I recently upgraded the memory and replaced the mobo in my HTPC. Below is my current setup:

Gigabyte MA790X-DS4 mobo
AMD Athlon 64 X2 4200+ processor
4 GB DDR2-800 RAM
Maxtor DiamondMax Plus 8 40GB IDE HDD
Maxtor 6V300F0 300GB SATA HDD
Western Digital WD10EACS 1TB SATA HDD
Running under Vista Home Premium (upgrade from XP Pro)
No RAID

Before performing any upgrades the entire system was running just fine (albeit a bit on the slow side with only 1GB mem). After replacing the motherboard I found that the BIOS couldn't find the 300GB Maxtor SATA drive. The WD one works just fine. If I shut down, unplug the SATA cable, plug it back in, and reboot everything works great... until I reboot again.

I've tried updating the BIOS, using different SATA cables, different power cables, different SATA ports, re-installing Windows using a SATA/RAID driver disk, and uninstalling the SATA/IDE controllers in Windows (allowing Windows to re-install them automatically). About the only thing I haven't tried is voodoo, though if anyone thinks that'll work I'm certainly open to giving it a shot. It's also worth noting that SATA is enabled in the BIOS, but the autodetect feature won't find the disk either.

I'm about at my wit's end here. Any help would be greatly appreciated!!

2
Contributors
2
Replies
3
Views
8 Years
Discussion Span
Last Post by rdeja
0

have you tried installing the 40GB hdd with OS and tried booting from there?
and once you're there go to control panel->administrative tools->disk management...then check whether it will be able to detect the 300gb hdd..if able to detect try to partition...

It seems weird but I encountered this problem before and the above trick seems to resolve my problem...

0

Yeah, that's how my system was set up from the start. The 2 larger disks are strictly storage. Disk management doesn't detect the disk unless I unplug/replug the disk, at which point it's miraculously recognized by the BIOS until I reboot. It's not the ports, since the 1TB drive works on all of them, and I don't think it's the drive, since it worked with the other board. Much more of this and I may just bite the bullet and get a new HDD...

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.