0

I have had a PC fail to boot with some pretty scary messages. Apparently (I didn't see it) there was a BSOD with the classic DOS type messages in a white courier typeface. I'm told that there was mention of missing or corrupt system files.

Then it refused to boot at all.

When I saw it, there was a DOS message about "failed to find Primary HDD".

I took out the C: drive (an "old school" 110Gb IDE ATA device) and put it in a caddy to look at in another machine. I changed the jumper from one end of the pins to the other (closest to the parallel connector). I believe this changes it from Master to Slave (am I right ?).

Upon powering up I can hear the drive spinning and clicking ... then I get the usual plug 'n play "ding" noises, and the messages pop up about finding a USB Mass Storage device and disk being ready (including the name and model of HDD) ... but it doesn't appear in "My Computer".

I looked in Device Manager and there it was - saying "this device is working properly". I have disabled and re-enabled it to no avail.

I ran Check It diagnostics and got a good report on my internal drives (C: and N: ) which have info for Physical and Logical aspects, but there is no mention of logical F: (where the USB device should have appeared). There are three HDDs in the physical section (#0 is C:, #1 is N: and #2 must be the USB caddy). Worryingly, the report on HDD #2 is bizarre :

Disk Size : 2 097 151 MB (that's 2 TERAbytes !)
No of Cylinders : -1 (yes, minus !)
No of Heads : 1
No of sectors/tracks : 1

Does this mean that there is something corrupt in the FAT (or equivalent - I think that the disk is actually formatted as NTSF) ?

Can this be fixed ?

I could dimantle another PC and put this drive into it as a second internal drive directly connected to the motherboard by IDE cable - would that yield different results ?

If I could find a PC professional, would they be able to work some sort of magic to at least address the data on the disk ?

[And yes, we do back up. This drive was backed up on 3rd July and has only been back in use since the 18th - so it's "only" two week's worth of incremental stuff we are talking about here. But we'd still like to get hold of it.]

Any help appreciated.


Regards

Graham

3
Contributors
5
Replies
6
Views
8 Years
Discussion Span
Last Post by hughv
0

In all cases I've seen, an external drive must be set to master. This setting is usually clearly marked on the drive, so don't guess.
Once you've got the jumper set correctly, look at this drive in Disk Management to get an accurate idea of what's up.

0

Oh, I see now. The jumper settings aren't written clearly on the top of the disk ... they are etched underneath.

When I try "Master" ... I get the same result.

"Check It" reports those bizarre figures I mentioned.

I've looked in Disk Management and there isn't even a mention of this disk existing.

When I look in Device Manager I can see the HDD and it is reported as "WDC WD1200JB-75RAO USB Device" which it claims is "working properly". I've disabled and re-enabled it to no avail.

As an aside, I don't understand jumper settings. This disk was working as the C: drive in a PC with the jumper nearest the power lead - which is clearly marked as "Cable Select". Shouldn't it have been set to "Master" ?

Regards

Graham

0

Ata hard drive's have 2 settings. Master or slave.
The master and slave settings set them as master or slave respectively.
The CS or Cable Select setting allow the drives to be set to master or slave automatically via their position on the data cable.

I still believe that the drive has had it though! I have seen those symptoms before, they were caused by one of the IC's severely overheating on the drive itself.

0

Doesn't look good. If you're sure you can't see it in Disk Management, it's probably toast.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.