0

Hello everyone,

First of all you need to know that my computer has two physical hard drives set up in RAID 0. The day before the problem started, there was a short power blackout, during which the computer was working (playing a movie), and I didn't have a UPS for the computer.

After the blackout everything was OK, and I finished the movie with no problem.

The next day I started the computer and after 30 minutes or so it crashed.

Since then when the computer starts the RAID controller reports that, while the logical drive status is "OK", the physical drive status of the first physical drive (number 0) reports "An Error Occurred (0)", while the second drive reports "Successful(0)".

After that the computer tries to boot the operating system but freezes exactly after showing the Windows logo.

I booted with Hiren's Boot CD the linux distro Parted Magic 6.6 and ran all three tests, including the Extended one which lasted 3h 40m, on both disks and both were successful.

Again from Hiren's Boot CD I booted Mini Windows XP, from which the files in the (logical) hard disk could be seen with no problem.
I ran check disk on the drive without checking the two check-boxes "Automatically fix file system errors" and "Scan for and attempt recovery of bad sectors" and it was once again successful.
After that I ran the same test with both check-boxes checked during the night and the next morning I found the computer frozen in the beginning of phase 5.

The computer is almost a year old.

I would appreciate any help

Thanks in advance...

PC Configuration:
CPU: Intel Core i7-950
MB: ASRock X58 Extreme
HDD: 2x WD Sata II 1 TB Caviar Black
OS: W7 and Ubuntu (dual boot)

2
Contributors
4
Replies
5
Views
6 Years
Discussion Span
Last Post by Orfikoss
0

Edit: I'm sorry the statuses reported by the raid controller are exactly:
Raid Volumes:
Volume_...__Status___Bootable

0__________Normal___Yes

Physical Disks:
Port_..._Type/Status(Vol ID)

0_______Error Ocurred(0)
1_______Member Disk (0)

PS: I used underscore instead of space so they are stacked

Edited by Orfikoss: n/a

0

Some more info:

When trying to boot from Ubuntu, the following message appears:

Gave up waiting for root device. Common problems:
 - Boot args (cat /proc/cmdline)
   - Check rootdelay= (did the system wait long enough?)
   - Check root= (did the system wait for the right device?)
 - Missing modules (cat /proc/modules; ls /dev)
ALERT! /dev/disk/by-uuid/dda4aa26-a60b-4046-8172-9a59f05eb5c9 does not exist. Dropping to a shell!

Also fyi the 5th pase of checkdisk in witch the computer crashes Chkdsk verifies unused clusters.

Edited by Orfikoss: n/a

0

I know this is an old thread, but since there are no answers and this is a big issue, I'll describe how I solved this issue: Just had to install the Intel Rapid Storage Technology software (on windows) and follow the indicated steps.

0

Thanks csantovsky.

After a while I reformatted my hard disks without raid and it has been like this since then. I think there is some kind of problem with one of the two disks...

Anyway, thanks again for your answer. I will have it in mind if I use raid again :)

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.