0

I have an older emachines c2280 that recently died. First it wouldn't power on at all, so I replaced the power supply. Now it won't go into POST or anything. It's not even sending a signal to the monitor. I'm thinking the cpu or motherboard?
Any ideas would be helpful.

3
Contributors
3
Replies
4
Views
11 Years
Discussion Span
Last Post by llmask
0

Is there a light on the motherboard? Is the power button flashing any colors? Do you hear the fans or hard drives try to spin up?

It is really likely that it is either the motherboard or the processor, and its hard to tell which without testing with known good ones. I would start with the motherboard, but it may be the processor.

0

Is there a light on the motherboard? Is the power button flashing any colors? Do you hear the fans or hard drives try to spin up?

It is really likely that it is either the motherboard or the processor, and its hard to tell which without testing with known good ones. I would start with the motherboard, but it may be the processor.

no light that i can see and the power button doesn't light at all, the hard drives are trying and the fan is spinning.

0

i also have the same issue.

but with mine, i hear the fan from the psu running, there is a green light on the power button.

i believe the hdd spins up.

what could it be? can it be the processor? or the mb?

or is it just safe to say to replace them both?

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.