0

Okay, I'm doing a reformat/clean install of XP Home on a Dell Inspiron 8100, service tag 6NZV111. This unit has the internal Actiontec 82559-based Ethernet Adapter and Modem Combo (MP100IM) that plugs into the Mini-PCI slot, and has two small multipin connectors to connect to the RJ-11 and RJ-45 jacks.

The card was working normally before the clean install, but afterwards, it barely works. By "barely works" I mean that it seems to work very slowly, if at all. For example, it takes several minutes after the desktop appears for the IP address to be configured via DHCP from my Netgear RP614v2 router, connected in turn to my Comcast cable modem. Once the IP address is finally assigned, if I try to browse the Internet, it can take several minutes for a page to load. If I do ipconfig /release , the adapter releases immediately. But ipconfig /renew gives me a An error occurred while renewing Local Area Connection : unable to contact your DHCP server. Request timed out. error message. If I let it sit for a few minutes, then ipconfig again, I find that the address has, in fact, finally been renewed.

If I plug in a USB ethernet dongle to the same machine/cable/router/etc, everything works likety-split. So I'm thinking it's driver issue, as the card was not physically handled during the reinstallation process.

This page says that XP provides the drivers needed for the NIC/modem combo. But when the XP default drivers didn't work, I did try the MP100IM.EXE driver for Win2k and the R33877.EXE driver for Win2k, both downloaded from Dell. (I rolled back to my post-clean-install restore point after each attempt.)

Device manager reports the unit as an Intel 8255x-based PCI Ethernet Adapter (10/100) and says it's working properly. The currently installed driver is Intel Corporation 5.41.22.0000 , dated 7/1/2001.

Any suggestions? Your help is very much appreciated.

2
Contributors
3
Replies
4
Views
11 Years
Discussion Span
Last Post by Amxo
0

Okay, an update here. Two distinct chat sessions with Dell went nowhere. The first tech pushed the 3com driver at me, which Windows wouldn't use, of course. The second didn't offer much either, other than installing XP Home yet again from scratch.

So I found a newer version (7.0.28.0) of the e100b325.sys driver that Windows was using, and that install went fine. But the problem persists.

Now, I ran some ping tests, pinging my router from the laptop, and see something odd. About 50% of the time, the reply is received in <1ms. The rest of the time it times out. So I'm thinking this is related to the "marginal connectivity" I'm experiencing.

The other curious thing is that the activity light on my router (a Netgear RP614v2) for the port I'm connected to keeps flashing rapidly, even when the network is not being used.

I have physically reseated the mini-PCI card. I also mated/unmated the two little multipin connectors several times to hopefully wipe out any corrosion that might have formed. I've tried a new ethernet cable, even though the old one worked fine with another NIC.

So I'm thinking that either my NIC is really toast or there's something wrong configuration-wise that's leading to the packet loss.

Ideas?

0

This is an old thread, but I wanted to say thanks. This problem was driving me crazy. It started when I connected my Dell 8100 directly to a Linksys WRT54G router. Changing the ethernet driver settings to 10mb/half duplex solved the problem.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.