0

First time entry into this sort of thing, so here goes.
I am the proud owner of a thinkpoad t22. PIII. She was working fine til i went on holiday/leave. Came back 3 months later to fire her up; Wouldn't do!
The green hard disk light blinks as you hit the start buttom but nothing more. I have dismantled everything i could, hard disk, batteries, RAM according to the manu manual, gave a good clean but... no change.
I know my main battery is pretty dead but on mains that shouldn't matter?! I was told sometimes the CMOS battery can lock things up, but i checked it and the voltage was 2.9, not bad.
The AC adaptors voltage is also fine, is my baby dead and bureied? :(

3
Contributors
9
Replies
11
Views
10 Years
Discussion Span
Last Post by shaun1914
0

Hello,

Before you inter your Thinkpad in to the digital Walhalla, have you checked the output of your power supply? Measure the voltage coming out and compare that to what it should be. This may be your culprit?

I wish I could give you better options but, I'm not used to working on laptops and they seem to develop a whole host of issues, unique to laptops.

Mustapha

0

Ive got a thinkpad similar to yours (model R30, 128mb ram, win98 and Pentium III 1ghz). Its battery is long dead also. It works fine though.

Does it start up if you phsycially remove the old main battery from the laptop?

If that doesnt work then try replacing the CMOS battery (there not that expensive but laptops can be tricky to open)

If that still doesnt work then it may be the Power Adapter. Ive broken two before as the wire has a tendancy to break over time if it is subjected to strain e.g rolling it up to put it in a laptop bag.

0

Thanks...

I checked the voltage on the CMOS battery, it was reading 2.9 which seems fine, the ac adaptor voltage was also reading ok.

No, it doesn't start with the battery removed, nothing either way! Any more ideas, thanks.

0

I don't think so, it's in apretty warm environment here in Africa, but it was working fine before i left.

Just tried the 'hold down' idea still no joy... when i press the power on switch the battery light goes off at the same time, can't remember if it used to do this before.

0

Wait, africa?

Have you killed it by using a travel adapter? (laptops dont like these) or maybe the humidity?

0

Nope, at least on the travel adaptor... and the humidity is not bad over here, she enjoyed a happy 3 years in an african climate before refusing to wake up!

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.