0

I have just installed apache.2 on my pc, along with php and mysql.
the problem started straight away with apache (or rather my setup) apache could not find port 80 or any other listening ports.
Now if you could give me some ideas how to solve this ( i presume little problem) I would be grateful :)

I am running XP home and have downloaded the service pack2

G

5
Contributors
6
Replies
8
Views
13 Years
Discussion Span
Last Post by viperman224
0

Thanks for the reply,
I have tried to disable windows firewall, then installing Apache again, but with no success. on installation it still reports an error make_sock: unable to bind to port 0.0.0.0.80.
I'm at a loss with ports and socketts :!: (unfortunately) so would appreitiate all the help anyone can give me.


Ta

G

0

I have finally been able to spend some time on resolving this problem.
The reason why apache could not create the win_sock is because, I had previoously installed xamp supplied by apachefriends, It seems that the exe had locked port 80 up, So I had to delete the xamp version from the exemptions in windows firewall.
Jobs a good one, I thought i would post this for future reference ;-)
Now I have another problem with accessing PhP http://127.0.0.1/myadmin.
i type the above in a browser expecting to see the myadmin page, but nothin except php code??

Any suggestions?


G

0

hmm, probably xamp installs a webserver of its own when running...
If you didn't know about this, that's nasty. Anyone know what it exposes to the world?

To run php in Apache you need a plugin (mod_php I think it's called), on its own Apache doesn't know heads or tails about php and will just serve the sourcecode as plain text.

0

You need to enable php support,

What is your OS and what version of apache are you running? :)

0

I use apache version 1.3, I had a friend inform me my ISP blocked port 80 and in order to get around it you have to configure the apache httpd file in the config folder of apache. Open the folder with notepad and use the notepad find feature search port 80 and then change port 80 to port 880 and save the file. I also use dyndns.org so your link would look like this http://example.ath.xc:880

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.