0

Found your site thru W3Schools, gave me new hope (almost ready to give up
on installing Apache..) basically I install Apache (from Apache.org-assume stable version..apache 2.0.54-win32-x86no_ssl) followed install tutorial, used
msi installer (localhost for domain name and server, and "administrator@localhost" for e-mail)...get error message when almost finished, also appears on log: syntax error..."Cannot load C:Web/modules/mod_access.so into server, the specified module could not be found. I don't even know what thay means lol Please someone help, this has been tying me up for days thanx :o

3
Contributors
26
Replies
28
Views
12 Years
Discussion Span
Last Post by webwannabee
0

You are in luck! Just Monday, I wrote a step-by-step HOWTO for setting up a WAMP system. That is Windows, Apache, MySql, and PHP. I include instructions to setup phpMyAdmin for managing your database. The tutorial is specific to Windows XP Home and Pro. It is in this Daniweb thread:
http://www.daniweb.com/techtalkforums/thread26579.html

Uninstall what you've done so far, and restart by following my tutorial. Please reply here to let us know how it goes.

By the way, a friend of mine tested the tutorial to set all this up on his Windows XP Home computer. He said he found no problems with my instructions and it took only about 30 minutes to do it. I hope many find it useful. I've asked Dani to make it a standard Tutorial on the site, although I've not heard a reply from her.

0

OMG...just sitting here (burnt out after trying to install various versions of Apache/php etc- the latest a bundled package of all three, Apache actually loaded, but there was a file saying I should actually get php sepearately and manually load it ahhhh...was up until 3 a.m. an no more enlightened...you are an angel!! will get to the bottom of this once and for all, but I hope u don't mind a pest because after it's all loaded, then I'm not sure what to do with it lol!!! Thanx again Troy :)

0

Thank you so much TROY!!! Have gone from 'this is a totally foreign country what am I doing messing with stuff like this" to, hmmm, some things starting to sink in, anyway, I have Apache installed, and after doing everything you said, I get the "Hello world' test page when I put http://localhost in browser...can't believe it, now on to PHP etc. one thing, don't know how I have 2 apaches running, I swear I uninstalled apache (add remove programs) and the program files (apache group) every 101 times (almost lol) I installed it and didn't work...oh well it works yippeee

0

Me again (the pest)..having a problem rite off the bat with php install..winrarred the php dld into a folder (C:/php/php50) but when right clicked on the php.in recommended file, and copied it, then tried to rename it as php.ini, it said I couldn't do this because php.ini already existed grrrr!!

0

Glad my instructions for getting Apache installed, configured, and tested worked for you! You are 25% there, my friend! Chin up!

First, unless you know what you are doing, and you obviously don't--right? :) Please unzip the PHP zip file into a folder named c:\php --not c:\php\php50. That is, create a new, empty folder named "php" on the root of your C:\ drive. Unzip the php zip file into it. MAKE SURE you unzip only the one file from php.net as instructed in the tutorial. For our purposes, do not download the other files they offer. Do not use the installer file.

Once unzipped to c:\php, you should not see a php.ini file in there. The zip file (at least the one I downloaded Monday) does not include a php.ini file. Rename php.ini-recommended to php.ini. If a php.ini exists already, then rename it to php.ini-OLD before making the new php.ini file. Continue with the HOWTO.

0

Thanx Troy..will try the PHP again (ya, I DON'T know what I'm doing, am counting on 'osmosis'...actually just doing it over and over and ..... :mrgreen:

0

c:\Program Files\Apache Group\Apache2\conf\httpd.conf is the active conf file you should edit. Keep attacking this--small steps at a time. You'll get it working.

0

Sorry, I didn't edit that silly message quick enuff, didn't want to waste your time, currently I have the Apache working again (phew) but don't know why it always says I have TWO on the system tray (one is usually on, and one is off, I make sure both are off when I do work on files...and turn ONE back on afterwards, although it's frustrating to see that error pop-up after I go through all the instructions for installing php..."cannot complete...operation has failed" arrggghh

0

You should be able to go into your Windows Control Panel, select Add/Remove Programs, and select to uninstall Apache. Since it's really easy to install and do the basic config, I recommend you uninstall Apache completely, then restart. Having two installations may be messing you up--it's definitely confusing, and since you are having trouble, let's get things cleaned up, then continue.

0

lol..you have patience for the noobs (boy, I'm slow lol) getting good at uninstalling, have done it like 40 times, but what I didn't do afterwards was RESTART, but have restarted just now, cause it says to for the php tut (the test page works when I turned Apache back on, through 'Programs..Apache' but the icon isn't in the systems tray at bottom of puter..oh well thanx again

update: Yay!! guess 1 third there now- have php tut done, am seeing the page I should at http://localhost(php info page)...SO exiting!! thanx Troy

0

k Troy, was hoping my next post would say I'm finished, and don't need to trifle you again but....using the MySql installer, clicking all the defaults, I get as far as "Install as Windows Service, ticked, and "MySql" in the box, and "Launch the MySql Service automatically" and get pop-up "a windows service with the name MySql already exists (swear I don't have any other versions in here) "Do you want to use this servicename".. 'yes'
enter password...press execute, first two boxes tick, but no 'start service', Cannot create Windows service for MySQL. error 0...so I gess I can't play :sad: :sad:

0

Your double Apache problem, and now MySQL install warning that service with name 'MySQL' already exists....you've definitely had MySQL installed (or an attempt to install) previously. Whether you did it or some product you installed put it on there for you. Depending on how MySQL was installed, you'll have MySQL in your Add/Remove Programs Controlpanel. Again, try removing everything MySQL related, then try again with MySQL install according to my HOWTO.

Good job getting Apache and PHP playing together and tested. That has to have you feeling at least somewhat better, eh? :)

Oh, and not to worry about not having Apache in the systray. You can just go to Start/Programs/Apache/... The service control utility is in there. It may have an option to click to put it back in the systray...I don't know about that, and I'm not on an Win/Apache computer at the moment or I'd check for you.

0

Thax Troy (remembered to reboot puter this time after uninstalling everyting mysql related...hope that's what it was, crossing fingers lol) ummm- had to add this: in the box that said 'MySql' as default, I scrolled down and picked 4.1(cause that's the file I'm installing right?) and gess what? got no error message, and finished the installation ok..crossing fingers again(still don't know why it said I had another mysql, cant find it, and rebooted a few times)

0

Followed the rest of the instructions to a T (they were simple and clear enough, but every time I get this: Fatal error: Call to undefined function mysql_connect() in C:\www\dbtest.php on line 8 when I go to http://localhost/dbtest.php to test it...now I think I will give up for a while :confused:

0

this is what's on line 8 of the code I pasted into that dbtest.php file created for c:/www/dbtest.php: if (!$cnn = mysql_connect($db_server, $db_user, $db_pwd)) {
echo mysql_error();.. am told there is an error on line 8, when I test the MySql

0

There is a section in the tutorial where it tells you to enable the mysql extension in the php.ini file. It definitely sounds like you did not do that. You need to uncomment this line in your php.ini file.

extension=php_mysql.dll
0

Well Troy, I did uncomment that line (ha ha, I'm picking up the lingo, and funny thing, stuff is starting to dawn on me how all this is done) with my very narrow grasp of this, all I can figure is maybe the version I downloaded has a 'corrupt' part in it, maybe the mysql line I uncommented itself, is calling some module somewhere that is giving me that error message, instead of what I should see...does that make sense to you somehow...or are you L.Y.A.O ahahhhaahhahaha (you don't know how much I appreciate your help up to now, and it's not wasted because I'm sure in a year from now I will look back on this and laugh and laugh.....)

0

OK, we are gonna get this figured out. You with me?! One step at a time now.

If you followed my instructions--and I'm sure you did :rolleyes: --, you'll have a directory named php on the root of your C:\drive. In this directory, you should have an ext directory.

c:\php\ext\

Notice in your c:\php\ext directory that there are 38 (or so) DLL files. These are the PHP extension modules. One of these is php_mysql.dll. Also notice the php.ini line I had you uncomment was extension=php_mysql.dll.

Now, when Apache starts, it will process this php.ini file. It will also try to load any extensions you have enabled. The way Apache finds the extension files can be affected a number of ways, but the way I tell you to do it is this:

Right-click My Computer and choose Properties. Choose the Advanced tab. Click the Environment Variables button at the bottom. In the System Variables section, click Path, then the Edit button. At the end of the path value, add ;C:\php;C:\php\ext Click OK and keep clicking OK until you exit out of the Properties. Reboot your computer.

If you had failed to do this path thing, then when you start Apache, you'd get warning messages popup telling you there were files that could not be found. Apache would go ahead and start, but you'd not have the mysql extension loaded. Not having the mysql extension loaded would produce the exact PHP error you are seeing--that is, the mysql commands don't even exist.

So are you seeing any error messages when you start Apache? You can check your Apache error log. If you did the default Apache install for Windows, it will be located at C:\Program Files\Apache Group\Apache2\logs\error.log. You can open this file in Notepad or your favorite text editor (PSPad or UltraEdit for example). If Apache cannot find the mysql extension dll, you'll see a line like this in the error log:

PHP Warning:  PHP Startup: Unable to load dynamic library './php_mysql.dll' - The specified module could not be found.\r\n in Unknown on line 0

Check through all this slowly--take you time to make sure you crossed all the t's and dotted all the i's.

0

Well, dotted the I's and crossed the t's (even dotted the t's and crossed the eyes-getting cross eyed- to be sure) HONEST, no error messages that u speak of, everything was ok until I created the dbtest file, think that's the problem (something that simple) I'm not doing that right...tried creating it different ways, sometimes it turns into a wordpad file, even tho I make it in notepad, but when it is a notepad file called dbtest.php, I get that 'page cannot be displayed' message, like I didn't make it rite...don't worry, I will try to call a friend out of hibernation to help (but will sure let you know what I did wrong) can't expect you to keep holding my hand lol

[client 127.0.0.1] script 'C:/www/dbtest.php' not found or unable to stat, referer: http://www.daniweb.com/techtalkforums/thread26579.html

0

I'm baa-aaack ha ha..well, could only get the advice to use php4.3.11 for some reason. And I tried to install that using your super guide but don't know what the adjustments would be...could you be so kind again, would sure appreciate it!! thanx

0

I work with Linux for my webserver needs--not Windows. I only created that HOWTO to help newbies because I had a friend needing to set this stuff up on Windows. I've used my HOWTO twice on 2 seperate machines (XP Home and XP Pro), and I've had 2 friends use it and report back they had no problems and everything worked well. So I know the instructions are good, and have proven successful on at least 4 different Windows XP machines. I think you are missing something fundamental, and from your posts, I cannot tell what that thing is. I don't think going a different direction is going to solve your fundamental issue. (i.e. I don't think going PHP4.3 is going to make this all work for you.)

I wish I had more to offer you at this point. I can offer you personal assistance, but I charge a small fee. What I've done in the past for people is setup a Windows Remote Assistance session. This allows me to remote control your computer and you can watch what I do. I can set this stuff up for you. It would take about 30 minutes total. PM me if you want to discuss this option. Please post additional questions here in the forums and myself and others will do our best to help.

0

I hear ya, you have gone 'above and beyond', lol, when I get this figured out, will post my 'mistakes' for other hard case noobs like me to learn from....or I will end up picking door number 2 (the option you mentioned lol) have a great summer Troy! *here's the scary part- when I can do it on Windows, then I will try it with Linux...just for fun aaaahhhhhhhhhhhh)

0

Hi y'all,
I am able to view localhost page and now I wanted to set up my website on my Apache server. I have a domaine name and IP address. where in httpd file should I make the changes so I can access my site from the outside world?
thanks

0

I am able to view localhost page and now I wanted to set up my website on my Apache server. I have a domaine name and IP address. where in httpd file should I make the changes so I can access my site from the outside world?
thanks

cider_or, this is a new discussion, so you should have started your own, new thread rather than tacking onto someone else's discussion. But to help you anyway...

Unless you are doing Virtual Hosting, you don't have to put your domain name in your Apache conf file, although you probably want to. You "have a domain name"...what do you mean by this? Did you register it with a service like GoDaddy or Network Solutions? Now you need a DNS server to provide the "zone" for your domain. You can setup your own DNS server, but you'd better KNOW what you are doing! You'll probably need to use a DNS service such as http://www.dyndns.org/. This allows you to associate your domain name with your public IP.

You said you "have an IP addres". Do you mean your ISP has assigned a static, public IP Address to your router? If so, great! You'll need to configure your router to send TCP port 80 traffic to your web server inside your network. Maybe you already understand this part of the equation.

0

Hey, just figured you all deserved an update, since you spent so much time helping me (even tho this is a month later yikes)...I just wanted to get on with learning/practicing php etc. and have a web serve set up to play on so....I CHEATED for now and just used NetServer to install everything (and that was even hard enough for ME lol).So I'll be checking out the other forums on php etc. thanx for all the help ;)

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.