0

Hey folks, wonder if someone could help me here?

I have a system with 3 seperate hard drives, and the first one is split in 2 with 4 GB per slice. I have windows 2000 on the first partition of that drive and was trying to install Redhat linux 9.0 on the second part using the Second Physical Drive as an application drive for linux. Forget the 3rd Hard Drive.

When I booted up the first CD of Linux I got and error -

Kernel Panic: VPS: Unable to Mount root fs on 48:05

I am gathering that there is some error in the File System.

Any solutions? Or should I just go with Mandrake Linux for the sake of knowing that one installs? :-)

Thanks in advance!

3
Contributors
8
Replies
9
Views
14 Years
Discussion Span
Last Post by Paladine
0

So you know mandrake definitely works on the partition but redhat won't for some reason? Unfortunately I don't know enough about the different linux distributions to know how each would handle installing to a partition differently. How far into the installation do you get? Are you able to select the partition you would like to install on and choose your packages, or you don't even get that far? Do you let the redhat installer reformat the partition as ext3 for you before installing?

0

Well actually I get that error message when I boot with the install CD and it just stops there. I get no further.

But now I tried to reinstall Windows on the same system (with out mandrake) and the CD is not being read. So I am thinking it is something with my CD ROM

Thanks for the help, I will let you know if it still doesn't work when I swap drives!

0

Okay, sounds good, get back to us. I can't see why the error would be "unable to mount root fs" as I would assume that would be related to writing to the hard drive? Perhaps it's having a problem loading the setup disk image to a temp folder of the hdd, or something of that sort?

0

OK, well it was partly the CD Rom. Now I have an issue where I am unable to install it because of 3 things..

1. Partitioning of one of the hard drives is not possible with Partition Magic (because a server OS exists there already...I want to keep).
2. When trying to partition using Disk Druid I get the error : No root set, unable to allocate space.
3. Another error because I have no swap "file" - that is easy to fix, if I can get the partition part figured out.

Thanks again...

0

Did you search at the site I posted you bra
ttp://linuxquestions.org/questions/history/85185
(suggestion)I always install any Linux(distro) last on the dual boot just because I like windows(XP) partion maybe you would have better luck trying it that way..........I always do a Xp fresh install every 3 months(mandatory) just because I think it runs better like that.

0

Thanks...Big "B" But, I have tried that. The problem is repartitioning after Windows 2003 Server is on the the drive already. Partition Magic is useless, and RH9 can't repartition it, nor will it install on a free drive. Just for the reasons I stated!

0

And now on second thought. I am going to just turf the Server...as it is easy to reinstall. And try RH9 on its ok. Thanks for you help and the web site...!

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.