0

Ok, Linux is suppose to be all powerful, or so they say... but what a pain it is to get things back to a normal...anyhow that is not why I am writing this post.

How do you install Forte for java 4 on linux if it is for linux?

I have the file jdk-1_4_0-i586-rpm.bin

Ok, so how do you get this thing to install. Kpackage does not recognize it since it is not a .rpm extension file, and running the konsole command rpm -iv <file-name as above> does nothing.

Anyone? Dani?

Thanks in advance....

2
Contributors
7
Replies
8
Views
14 Years
Discussion Span
Last Post by Dani
0

---continuance from above:

I have downloads the following file j2sdk-1_4_1_01-linux-i586.bin and tried to execute the file by double clicking on it in KExplorer (KDE) and tried to execute it by typying the file name in the konsole. Nothing happens.... so then i found this link http://www.linuxjournal.com/article.php?sid=6290 and still can't seem to figure it out.

Anyone?


I even have the Java Forte 4 CD (community edition) and have been unable to run/execute any of the bin files on it to install the software , jre, or sdk for Java.

Thanks in advance..

p.s. Running Red Hat Linux 7.2 on a Pentium 2 300

0

Well ..... hmm ....

I've been able to execute rpms and I've been able to execute bins..... which one is it?

I've come across executables with the .bin extension which have been distributed without executable permissions. Make sure that you're the owner of the file and that read/write/execute permissions are available to you. (e.g. chmod 700) Then you should be able to run ./file.bin from a terminal.

0

btw... you say you tried running it by typing out its name in a konsole. just wanna make sure you know to browse to the directory the file's located in, make sure you have executable permissions, and then type

./filename.bin

g'luck :)

0

Thanks cssgal, I got some help and this is what I needed to do...

# chmod u+x ~root/j2sdk-1_4_1_01-linux-i586.bin
# mkdir /usr/local/java
# cd /usr/local/java
# ~root/j2sdk-1_4_1_01-linux-i586.bin

and it worked. Dunno why? Permissions is part of it.

This massive book ("Complete Reference to Linux) is a piece of you know what. And a waste of money.

So now I need to step back and read some stuff and the linux documentation project and linuxnewbie websites before I bang my head any further.. :-)

chmod? It is not even really explained well in the book..... although it does say chmod u+x sets the files' executable permission. Say what?

....guess back to the "books"

0

The commands you showed are EXACTLY what I said to do. Chmod'ing a file means changing its permissions (to the best of my knowledge). You gave the file permission to read and execute it. And then you made a /usr/local/java directory. And then you executed the file you just finished giving execute permissions. ;)

0

...duely noted. And I agree, but saying how and knowing how are two different things. You knew both and I only knew what to do, not how to do it.

<bowing in your presence>

...back to the books I go I guess.

:-)

0

hehe good luck
... linux isn't too bad once u get the hang out it; i'm still most definitely a newbie myself ;)

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.