0

Hi,

I have apache2 running on Ubuntu 9.04. I am trying to set up vhosts. I have two files in sites-enabled there contents are:

<Directory /var/www/video>
    AllowOverride All
    Order Allow,Deny
    Allow from all

AddType text/html .htm
</Directory>

<VirtualHost *:80>
      DocumentRoot /var/www/video
      ServerName jvids.co.uk
      Serveralias www.jvids.co.uk
     ServerAdmin jameslovejoy1@googlemail.com
</VirtualHost>

That was called jvids.co.uk

and the other is called 000-default:

<VirtualHost *:80>
	ServerAdmin webmaster@localhost

	DocumentRoot /var/www
	<Directory />
		Options FollowSymLinks
		AllowOverride None
	</Directory>
	<Directory /var/www/>
		Options Indexes FollowSymLinks MultiViews
		AllowOverride all
		Order allow,deny
		allow from all
	</Directory>

	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
	<Directory "/usr/lib/cgi-bin">
		AllowOverride None
		Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
		Order allow,deny
		Allow from all
	</Directory>

	ErrorLog /var/log/apache2/error.log

	# Possible values include: debug, info, notice, warn, error, crit,
	# alert, emerg.
	LogLevel warn

	CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>

I get this when restarting apache:

* Restarting web server apache2                                                [Sat Feb 20 15:01:42 2010] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Sat Feb 20 15:01:42 2010] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Sat Feb 20 15:01:42 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
[Sat Feb 20 15:01:42 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
 ... waiting ..[Sat Feb 20 15:01:47 2010] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Sat Feb 20 15:01:47 2010] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
[Sat Feb 20 15:01:47 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
[Sat Feb 20 15:01:47 2010] [warn] NameVirtualHost *:80 has no VirtualHosts
                                                                         [ OK ]

What is wrong with it?

2
Contributors
1
Reply
2
Views
7 Years
Discussion Span
Last Post by khess
0

My suggestion is to install webmin and use it to configure your virtual hosts. If that, for some reason is not an option, let me know and I'll tell you how to do it using the scripts.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.